Rang und Sverweis

26/05/2009 - 14:41 von Annakanda | Report spam
Hallo zusammen,

ich versuche schon den ganzen Tag, eine Lösung für 2 Excelprobleme zu finden
und hoffe, ihr könnt mir weiterhelfen.

Am besten schilder ich die Situation: Ich möchte Daten in einer großen
Tabelle übersichtlich aufbereiten. Dazu benötige ich 2 andere Excel-Tabellen.

Problem 1:

Ich habe die Daten in folgender Form bekommen und das Ganze hier vereinfacht
dargestellt. Die Tabelle hat 8.000 Zeilen, dabei stehen untereinander immer
die Top 10 Artikel (nach Nachfrage Wert) einer Warengattung.

Rang Warengattung Artikel

1 Jeans
Jeans I
2 Jeans
Jeans II
10 Jeans
Jeans X
1 Hemden
Hemd I
10 Hemden
Hemd X

Nun möchte ich die Top 10 Artikel der 10 besten Warengattungen in mein
Auswertungsblatt übernehmen.

Ich habe es mit
=SVERWEIS(1;'[Aktionskalender_20090519_MF.xls]Top 10 je WGT
NFStueck'!$A$8:$L$7929;3;WAHR)
probiert, aber dabei bekomme ich als Ergebnis nur den Artikel, der in der 1.
Zeile meine Tabelle steht.

Ich brauche jedoch nicht den 1. Rang in der 1. Zeile meiner Tabelle, sondern
den 1. Rang einer bestimmten Warengruppe. Wie kann ich das einbauen?

So klappt es leider auch nicht. In diesem Versuch heisst die Warengruppe
00850 Computer.

=WENN('[Aktionskalender_20090519_MF.xls]Top 10 je WGT NFStueck'!E:E="00850
COMPUTER";SVERWEIS(1;'[Aktionskalender_20090519_MF.xls]Top 10 je WGT
NFStueck'!$A$8:$L$7929;7))

Auch mit Klicken auf die Zelle, in der 00850 Coputer steht, funktioniert es
nicht.

Problem 2:

Die Tabelle (11.000 Zeilen, 100 Spalten) ist wie folgt aufgebaut:

Ebenen 0 bis 7 NF Jan 09 NF Feb 09 CR Jan 09 CR Feb
09

Aus diesem Datenmeer benötige ich auch die Top 10 (nach Nachfrage Jan 09),
jedoch stellt sich die Top 10 wie folgt zusammen:
In der Ebene 1 muss "Aktuelles" stehen, in der 2. und 3. Ebene irgendetwas
und in der 4.-7. nichts. (Alle anderen Fàlle/Befüllungen der Ebenen sollen
nicht zàhlen.)

Habs damit bei einer kleineren Datenmenge probiert:
=WENN(UND(E8:E36="Aktuelles";G8:G36<>"";H8:H36="");RANG(BW36;BW8:BW36))
Leider ohne Erfolg. :( Das Problem müssten hier die Spalten(z. B. E8:E36)
sein.

Ich hoffe wirklich, ihr habt dafür einen Tipp. Wenn der Rang dann erstellt
ist, wàre es super, wenn man das mit einem Sverweis kombinieren kann.
Alsowenn Rang 1, dann Sverweis.

Ganz vielen Dank für eure Hilfe!
 

Lesen sie die antworten

#1 Alexander Wolff
26/05/2009 - 16:18 | Warnen spam
Kennst Du Autofilter? Dort ist "Top 10" sogar schon vorgesehen.

Du könntest nun ein Makro aufzeichnen und alle Top 10 in eine neue Tabelle
untereinander kopieren ... ein Kinderspiel, da es sich um feste Satzanzahlen
handelt.

Auch jede beliebige Kombination von UND-Bedingungen ist damit gegeben,
beschrànkt natürlich durch die Erklàrung etwa von
http://excelformeln.de/formeln.html?welcher5. Jedoch verwendet man eh
immer ein flexibles Feld mit einer temporàren Formel beim anspruchsvollen
Autofiltern.

Willst Du hàndisch weiter laborieren, nimmst Du =KGRÖSSTE(), nicht =RANG().
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen