Rb-Rubygems 1.35 updaten

03/03/2010 - 08:40 von Aku | Report spam
Hallo an die Gruppe,
ich habe mir unter Mac OS X 10.4 via MacPorts Ruby 1.87 und Rb-
Rubygems 1.35 installiert. Leider verweigert gem seinen Dienst mit der
Fehlermeldung:

spec_fetcher.rb:232: warning: getc is obsolete; use STDIN.getc
instead

MacPorts ist der Fehler gemeldet worden, aber wann sich da etwas tut
ist ungewiss. Es gibt ja auch schon neuere Rubygems Versionen. Meine
Frage ist nun, ob und wie ich Rubygems ohne MacPorts updaten kann.

sudo gem update

brachte die Meldung, dass es keine gems zum updaten gàbe. Und

sudo gem update -system

ERROR: While executing gem ... (OptionParser::AmbiguousOption)
ambiguous option: -system

Danke für Eure Hilfe
 

Lesen sie die antworten

#1 Aku
03/03/2010 - 11:20 | Warnen spam
On Mar 3, 8:40 am, Aku wrote:
Hallo an die Gruppe,
ich habe mir unter Mac OS X 10.4 via MacPorts Ruby 1.87 und Rb-
Rubygems 1.35 installiert. Leider verweigert gem seinen Dienst mit der
Fehlermeldung:

 spec_fetcher.rb:232: warning: getc is obsolete; use STDIN.getc
instead



Problem gelöst, durch Installation eines anderen Ruby Paketes.

Ähnliche fragen