Re: [gentoo-user-de] LVM2 und Kernel 2.6.25

08/05/2008 - 20:30 von Bernhard Auzinger | Report spam
Am Donnerstag 08 Mai 2008 schrieb Florian Philipp:

On Thu, 2008-05-08 at 19:48 +0200, Bernhard Auzinger wrote:
> Hallo,
>
> ich benutze LVM2 und habe meinen Server gestern auf Kernel 2.6.25
> umgestellt. Beim hochfahren wurden meine LVM's nicht mehr erkannt. Auch
> mit vgscan hatte ich keinen erfolg. lvscan zeigt mir auch nichts an.
> Ich habe danach versucht mit dem alten Kernel (gentoo 2.6.24-r2) zu
> booten. Mit diesem habe ich jedoch aufeinmal dasselbe Problem.
>
> Ich habe mittlerweile herausgefunden, dass es am neuen sysfs-Layout
> liegt und man im Kernel auch das alte einkompilieren kann um die
> Kompatibilitàt mit einem àlteren LVM2 herzustellen. Jedoch bringt mir
> das die Daten auch nicht wieder. Hat jemand von Euch eine Ahnung, wie
> ich die LV's wiederherstellen bzw. meine Daten wiederbekommen könnte?
>
> LG
> Bernhard

Ein paar Schüsse ins Blaue:
/etc/lvm/lvm.conf auf Richtigkeit überprüfen
vgck -v
lvmdiskscan
Eine neuere Version von LVM testen



Die lvm.conf sollte richtig sein, da ich daran nichts geàndert habe.
Mit dem alten Kernel sollte es ja noch funktionieren.

vgck -v und lvmdiskscan haben keinen Effekt. lvmdiskscan sagt mir, dass
ich zwei PV's habe. vgck -v gibt nichts aus (keine vg's)


Eine neuere Version von LVM testen


Das hört sich einfacher an, als es ist, wenn sich fast alles samt /usr
in lv's befindet, die ich nicht mehr lesen kann und ich mit dem Server
nur eine serielle Verbindung habe.

LG
Bernhard



gentoo-user-de@lists.gentoo.org mailing list
 

Lesen sie die antworten

#1 Florian Philipp
08/05/2008 - 21:00 | Warnen spam


On Thu, 2008-05-08 at 20:28 +0200, Bernhard Auzinger wrote:
Am Donnerstag 08 Mai 2008 schrieb Florian Philipp:
> On Thu, 2008-05-08 at 19:48 +0200, Bernhard Auzinger wrote:
> > Hallo,
> >
> > ich benutze LVM2 und habe meinen Server gestern auf Kernel 2.6.25
> > umgestellt. Beim hochfahren wurden meine LVM's nicht mehr erkannt. Auch
> > mit vgscan hatte ich keinen erfolg. lvscan zeigt mir auch nichts an.
> > Ich habe danach versucht mit dem alten Kernel (gentoo 2.6.24-r2) zu
> > booten. Mit diesem habe ich jedoch aufeinmal dasselbe Problem.
> >
> > Ich habe mittlerweile herausgefunden, dass es am neuen sysfs-Layout
> > liegt und man im Kernel auch das alte einkompilieren kann um die
> > Kompatibilità¤t mit einem à¤lteren LVM2 herzustellen. Jedoch bringt mir
> > das die Daten auch nicht wieder. Hat jemand von Euch eine Ahnung, wie
> > ich die LV's wiederherstellen bzw. meine Daten wiederbekommen könnte?
> >
> > LG
> > Bernhard
>
> Ein paar Schà¼sse ins Blaue:
> /etc/lvm/lvm.conf auf Richtigkeit à¼berprà¼fen
> vgck -v
> lvmdiskscan
> Eine neuere Version von LVM testen

Die lvm.conf sollte richtig sein, da ich daran nichts geà¤ndert habe.
Mit dem alten Kernel sollte es ja noch funktionieren.

vgck -v und lvmdiskscan haben keinen Effekt. lvmdiskscan sagt mir, dass
ich zwei PV's habe. vgck -v gibt nichts aus (keine vg's)

> Eine neuere Version von LVM testen
Das hört sich einfacher an, als es ist, wenn sich fast alles samt /usr
in lv's befindet, die ich nicht mehr lesen kann und ich mit dem Server
nur eine serielle Verbindung habe.

LG
Bernhard




Schau dir mal vgcfgrestore an. Die Backups befinden sich
in /etc/lvm/backup und können mit less angesehen werden.

Ich à¼bernehme aber keine Garantie dafà¼r, dass das funktioniert. Besser
du machst ein Backup oder fragst jemanden von LVM danach. Da gibt es
doch mit Sicherheit Mailing-Listen.




mailing list

Ähnliche fragen