Re: USB-Kabel EMVerträglich

03/12/2013 - 07:48 von all2001 | Report spam
On 03 Dec 13 at group /de/sci/electronics in article bg4n4gF7p1U1@mid.individual.net
<hurga-news2@tigress.com> (Hanno Foest) wrote:


Am 03.12.2013 00:35, schrieb Wolfgang Allinger:


XP zeigt den Thread so an:
01.12 Norbert Goettsche USB-Kabel EMVertrAxglich
01.12 +-Frank Scheffski Re: USB-Kabel EMVertràg lich

XP zeigt typisch an, wenn das subject veràndert wurde.



XP sollte besser mal korrekt dekodieren.


Da kannst Du sehen, dass der NG mit (Ax) und der FS mit (<SP>) ihre
Mailer flasch eingestellt haben und ich keine subjects veràndert
habe:



Unsinn. NG hat ein korrekt mit UTF-8 encodetes Subject und FS ein
korrekt mit ISO-8859-1 encodetes Subject gesendet.



Nö. s.u.




Hinter meinem Namen taucht nie das subject auf, d.h. ich schicke das
vorherige subject 1:1 unveràndert raus.



XP dekodiert beides falsch und schickt es entsprechend auch wieder
falsch raus (so viel zu nicht veràndern).


Du klàffst den flaschen Baum an.



Si tacuisses.



Na wenn Du meinst XP kann kein UTF-8...

Die Mailer von NG und FS halten sich nicht an:

x8
An important note for developers of UTF-8 decoding routines: For
security reasons, a UTF-8 decoder must not accept UTF-8 sequences that
are longer than necessary to encode a character. For example, the
character U+000A (line feed) must be accepted from a UTF-8 stream only
in the form 0x0A, but not in any of the following five possible overlong
forms:

0xC0 0x8A
0xE0 0x80 0x8A
0xF0 0x80 0x80 0x8A
0xF8 0x80 0x80 0x80 0x8A
0xFC 0x80 0x80 0x80 0x80 0x8A

aus: http://www.cl.cam.ac.uk/~mgk25/unicode.html
8x

Deinem Mailer isset offensichtlich egal, er hàlt sich auch nicht an die
obige Regel, deswegen siehst Du es nicht, bzw. er zeigt es an als
normales Zeichen.


Und nu?

Hab übrigens den kompletten Thread nicht mehr, auch keine MSG-ID,
sondern nur noch:

8x
09-22-2011
Thomas Niering

Beitràge: n/a
Standard Re: Falsche UTF-8 Decodierung?

Hallo Jörg,

Jörg Tewes <jogi1964.gmx.> wrote:

angucken? Ist die Codierung im From korrekt?



*seufz*
Ein weiterer Scherzkeks, der meint, das alles, was sein Reader korrekt
anzeigt, auch überall korrekt angzeigt und übertragen wird.


Weil bei mir wird nàmlich statt dem T nur ein seltsames Rechteck angezeigt.



Das ist ein etwas anderes T, liegt nicht im anzeigbaren Bereich von XP und
wird dir deswegen so angezeigt.

Ciao Thomas
x8

Egal, hab keine Lust den Glaubenskrieg um richtige und flasche UTF-8
wieder auszugraben.

Gehört hier eh nicht hin. Drum EOD




Saludos (an alle Vernünftigen, Rest sh. sig)
Wolfgang

Wolfgang Allinger, anerkannter Trollallergiker :) reply Adresse gesetzt!
Ich diskutiere zukünftig weniger mit Idioten, denn sie ziehen mich auf
ihr Niveau herunter und schlagen mich dort mit ihrer Erfahrung! :p
(lt. alter usenet Weisheit) iPod, iPhone, iPad, iTunes, iRak, iDiot
 

Lesen sie die antworten

#1 all2001
03/12/2013 - 07:59 | Warnen spam
On 03 Dec 13 at group /de/sci/electronics in article
(Wolfgang Allinger) wrote:
[...]

Egal, hab keine Lust den Glaubenskrieg um richtige und flasche UTF-8
wieder auszugraben.

Gehört hier eh nicht hin. Drum EOD




Sorry, beim Sendeversuch ist in W7 die DOS-box mit XP abgekackt,
beim erneuten Versuch W7 totaler Absturz.

Bezugsverkettung ist nun zerstört, hab keine Ahnung, wie ich das mit XP
beheben kann, wenn überhaupt.

Scheint auch evtl. doppelt rausgegangen zu sein.
Weiss nicht welche ich canceln kann/darf, damit nicht noch mehr
Verwirrung auftritt, also fummel ich nicht weiter rum.

Egal, sozusagen ein EOD von höherer Gewalt :)






Saludos (an alle Vernünftigen, Rest sh. sig)
Wolfgang

Wolfgang Allinger, anerkannter Trollallergiker :) reply Adresse gesetzt!
Ich diskutiere zukünftig weniger mit Idioten, denn sie ziehen mich auf
ihr Niveau herunter und schlagen mich dort mit ihrer Erfahrung! :p
(lt. alter usenet Weisheit) iPod, iPhone, iPad, iTunes, iRak, iDiot

Ähnliche fragen