Realtek RTL8111 - Hänger mit rtgnda12 (RTL8169)

18/10/2007 - 21:49 von Andi B. | Report spam
Hallo,
bei meinem neuen MSI Motherboard ist ein RTL8111 verbaut. Prinzipiell
funktioniert der Chip mit den 8169 Treiber. Er meldet sich eigentlich als
8168er, ist so aber auch in den Treibersourcen angemerkt.

Das Problem ist nur, daß sich der Rechner immer wieder nach einiger Zeit
aufhàngt. Nicht mal der Mauszeiger bewegt sich mehr. Einige Zeit davor antwortet
dieser Rechner nicht mehr auf pings.

Ich vermute, daß dies ein IRQ Problem ist. Leider làßt sich bei diesem
Motherboard bezüglich IRQs nicht's drehen. Das meiste hàngt am INTA welcher auf
IRQ11 geroutet wird. Alle onboard Komponenten hab ich schon deaktiviert.

Die Installation von eCS2.0rc2 mit ACPI Treiber führt zu einem Trap, weshalb ich
ACPI nicht installiert habe. Ich denke aber auch damit würden sich die IRQs
nicht besser verteilen lassen.

Nachdem nun schon alles deaktiviert ist, bleibt eigentlich nur mehr die Matrox
PCI Graphikkarte welche sich mit dem 8111 beißt. Der letzte snap (ca. 3.1.8) ist
installiert. Ein Indiz dafür ist auch, daß snap manchmal meint, die Matrox hàtte
nur 3 oder gar 2MB RAM.

Eigentlich hàtte ich gedacht, daß weder snap noch der Realtek Treiber mit IRQ
sharing haben sollte. Ich habe schon eine Menge 8139er laufen gehabt, immer
problemlos.

Weiß jemand von solchen Problemen mit dem 8169er Treiber, oder noch besser eine
Lösung?

Grüße,
Andi
 

Lesen sie die antworten

#1 Marcel Müller
19/10/2007 - 00:03 | Warnen spam
Andi B. wrote:
Das Problem ist nur, daß sich der Rechner immer wieder nach einiger Zeit
aufhàngt. Nicht mal der Mauszeiger bewegt sich mehr. Einige Zeit davor
antwortet dieser Rechner nicht mehr auf pings.

Ich vermute, daß dies ein IRQ Problem ist.



Mag sein.
Es mag aber auch sein, dass der Treiber für die 816x die falschen
Workarounds für die Hardware-Bugs im Chip hat.

Nachdem nun schon alles deaktiviert ist, bleibt eigentlich nur mehr die
Matrox PCI Graphikkarte welche sich mit dem 8111 beißt. Der letzte snap



Der Treiber verwendet keinen IRQ.

(ca. 3.1.8) ist installiert. Ein Indiz dafür ist auch, daß snap manchmal
meint, die Matrox hàtte nur 3 oder gar 2MB RAM.



Meine MGA-RAMs produzieren gerne mal Lesefehler, wenn sie zu schnell
über den Bus angesprochen werden. Ein Testprogramm von c't behauptet das
jedenfalls beim Zugriff auf das Video-RAM. Mag sein, dass das SNAP aus
dem Takt bringt.


Eigentlich hàtte ich gedacht, daß weder snap noch der Realtek Treiber
mit IRQ sharing haben sollte. Ich habe schon eine Menge 8139er laufen
gehabt, immer problemlos.



Ich glaube auch nicht, dass es am IRQ-Sharing liegt.


Marcel

Ähnliche fragen