Regelung von Schaltnetzteilen

15/04/2012 - 16:00 von Manfred W. | Report spam
Hi!

Ich habe ein Schaltnetzteil gebaut. Die Topologie ist einer Vollbrücke
àhnlich, mit PWM-Ansteuerung (im Gegensatz zu phase shift). Es ist eine
peak-current-mode-Regelung mit einem deutlichen voltage-mode-Anteil (zwecks
slope-compensation). Der verwendete Controller
http://www.national.com/pf/LM/LM25037.html ermöglicht das recht einfach. Die
ganze Regelung ist recht typisch aufgebaut: Typ 2 - Kompensation, TL431 und
Optokoppler.
Das ganze funktioniert ganz ordentlich, mit einer Einschrànkung:
Man betreibt das Netzteil im Leerlauf, schaltet es aus und dann gleich
wieder ein. Der Ausgangselko ist dann beim Wiedereinschalt-Zeitpunkt nur
wenig entladen. Leider schießt dann die Ausgangsspannung sehr deutlich über
den Sollwert. Der Regler reduziert halt bei Erreichen der Ausgangsspannung
viel zu spàt den duty cycle. Der Softstart ist bereits sehr langsam
gestaltet, das ist keine mögliche Lösung.

Die open-loop-Verstàrkung habe ich mit einem frequency-response-analyzer
gemessen. Dabei ist feststellbar, dass im Leerlauf die Verstàrkung
dramatisch einbricht. Woran liegt das genau? Muss man das darauf
zurückführen, dass der Ausgangsstrom im Leerlauf zwangslàufig lückt? Wie
könnte man oben beschriebenes Problem beheben?

mfg

Manfred W.
 

Lesen sie die antworten

#1 Newdo
15/04/2012 - 20:22 | Warnen spam
Am 15.04.2012 16:00, schrieb Manfred W.:
Die open-loop-Verstàrkung habe ich mit einem frequency-response-analyzer
gemessen. Dabei ist feststellbar, dass im Leerlauf die Verstàrkung
dramatisch einbricht. Woran liegt das genau? Muss man das darauf
zurückführen, dass der Ausgangsstrom im Leerlauf zwangslàufig lückt? Wie
könnte man oben beschriebenes Problem beheben?



Ein bekanntes Problem. Ohne eine Mindestlast geht der Regler in den
diskontinuirlichen Betrieb über.

Bei minimaler Aussteuerung (duty-cycle) wird eine Mindestenergiemenge in
den Speicherkondensator transportiert, die verzögert abgebaut wird.

Gruss Udo

Ähnliche fragen