Remote Client Verbindung wird plötzlich getrennt, bleibt aber akti

14/09/2008 - 22:17 von Robert | Report spam
Servus,

ich habe ien Problem mit meinem Windows Webserver 2008.

Bisher lief alles wunderbar. Nachdem ich dann einige Features im
Servermanger installiert und wieder deinstalliert hatte gibt es plötzlich
Fehler bei der Clientanbindung über Remotedesktop und weitere.

Der Grund für die Deinstallation und Installation verschiedener Features,
war, dass ich Easyprint nutzen wollte, bis ich gemerkt habe, dass es nicht
daran liegt, sondern das der Server nicht im Anwendungsmodus làuft, aber das
ist ein anderes Thema.

Installiert und deinstalliert habe ich Drucker, LDAP und
Druckerverwaltungstools. Zusàtzlich habe ich die Gruppenrichtlinien
installiert und deinstalliert, was glaube ich zu dem Fehler führt.

Der Fehler bschreibt sich wie folgt:

Ich kann mich per Remotedesktop (RDP) normal an den Server verbinden, und
daran arbeiten. Wenn ich aber ein paar Minuten nichts mache, wird die
Verbindung getrennt und ich komme eventuell nicht mehr auf den Server, da
manchmal die andere Remoteverbindung belegt ist und meine unterbrochene auf
dem Server noch aktiv ist. Die muss ich dann erst von dem anderen User der
aktiv ist abmelden lassen.

Auf dem Client kommt nur die Fehlermeldung, dass die Verbindung getrennt
wurde.

Im Ereignisprotokoll erscheinen mehrere Fehlermeldungen:

1.
"Catalog Database (12) Catalog Database: Versuch, die minimale
E/A-Blockgröße für Datentràger "C:\" (enthàlt
"C:\Windows\system32\CatRoot2\") zu ermitteln, ist mit Systemfehler 5
(0x00000005): "Zugriff verweigert " fehlgeschlagen. Fehler -1032
(0xfffffbf8)."

2.
Vom Kryptografiedienst konnte die Katalogdatenbank nicht initialisiert
werden. Der "ESENT"-Fehler war: -1032.

3.
Der Dienst "DgiVecp" wurde aufgrund folgenden Fehlers nicht gestartet:
Das System kann das angegebene Geràt nicht finden.

4.
Der Dienst "Diagnoserichtliniendienst" wurde mit folgendem Fehler beendet:
Zugriff verweigert


wenn ich mir z.B. die erste Fehlermeldung mal anschaue ist unter dem Link
kaum eine Datei zu finden.
auf meinem anderen Server sind unter catroo2/{F...} die catdb Datei zu
finden, diese ist bei dem beschriebenen Server nicht da.

ich habe auch folgendes Versucht:

Methode 3: Ordner "Catroot2" umbenennen
Benennen Sie den Ordner "Catroot2" um (gilt nur für Windows XP und Windows
Server 2003) und versuchen Sie dann erneut, das Programm zu installieren.

Hinweis: Überspringen Sie diese Methode, wenn Sie mit Windows 2000 arbeiten.

Gehen Sie folgendermaßen vor, um den Ordner "Catroot2" umzubenennen:
1. Klicken Sie auf Start und auf Ausführen, geben Sie cmd ein, und klicken
Sie auf OK.
2. Geben Sie die folgenden Befehle in der Eingabeaufforderung ein, und
drücken Sie nach jedem Befehl die [EINGABETASTE].
net stop cryptsvc
ren %systemroot%\System32\Catroot2
oldcatroot2
net start cryptsvc
exit
3. Entfernen Sie alle Dateien des Typs "tmp*.cat" aus dem folgenden Ordner:
%systemroot%\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}


Wenn in diesem Ordner keine Dateien vorhanden sind, die mit "tmp" beginnen,
entfernen Sie keine sonstigen Dateien. Die CAT-Dateien in diesem Ordner
werden für die Installation von Hotfixes und Service Packs benötigt.
Wichtig: Sie dürfen den Ordner "Catroot" nicht umbenennen. Der Ordner
"Catroot2" wird von Windows automatisch neu erstellt. Wenn Sie den Ordner
"Catroot" umbenennen, wird dieser jedoch nicht neu erstellt.

da sagt er mir aber im CMD window, dass der Zugriff verweigert wurde, also
wurde der neue Ordner nicht erstellt.

Wenn ich den Dienst manuel beende und den Ordner umbenenne, dann klappt das
und bei einem Neustart wird auch der neue Ordner angelegt, allerdings sind
die ganzen ordner dann leer (Versteckt Dateien werden nat. auch angezeigt.).

Kann mein Problem überhaupt mit dem Kryptographiedienst zusammenhàngen? Kann
das durch die deinstallation der GPO passiert sein?

Weiss jmd mir zu Helfen? weil Neuaufsetzen will ich den Server eigentlich
nicht, da ich dann erstens nicht weiss, was nun falsch war, und 2. dies
wieder ewig viel Zeit in Anspruch nimmt :)

Hillfe Hilfe,

Gruß

Robert
 

Lesen sie die antworten

#1 Robert
15/09/2008 - 14:45 | Warnen spam
ich habe festgestellt, dass früher die Funktion ging, dass man wenn die
Sessions belegt sind, die User aufgelistet bekommt, und diese disconnecten
kann. Jetzt funktioniert das nicht mehr und mein RDP Cliet sagt nur, dass die
Verbindung nicht hergestellt werden kann (wenn alle Sessions belegt sind).

Wo kann man das einstellen, dass man die Auswahl wieder zur Verfügung hat,
das würde mir schon sehr weiterhelfen

Ähnliche fragen