Reporting Services im Integrierten Sharepointmodus

15/09/2008 - 20:14 von Tobias Müller | Report spam
Hallo liebe NG,

ich habe versucht einen Berichtsserver im integrierten Sharepointmodus
zu installieren, aber leider werden die Inhaltstypen nicht erzeugt (bzw.
sie stehen auf jeden Fall nicht zur Verfügung). Das hat zur Folge, dass
ich keine Berichtigungen auf Berichtsmodellelemente vergeben kann.

Folgendes habe ich gemacht:

Auf einem Windows Server 2003 SP2 Sharepoint Services 3.0 mit Add-In für
Reporting Services installiert, SQL 2008 Reporting Services und BIDS.

Als erstes habe ich im Visual Studio-BIDS ein neues Berichtmodell
erstellt. Als Pfadangaben habe ich ein eine Sharepointbibliothek
genommen, die ich natürlich vorher schon erstellt hatte. Das Modell habe
ich dann erstellt und bereitgestellt. Keine Fehler! Achja die
Datenquelle verweist auf eine DB die auf einem 2. SQL 05 liegt.

Als nàchstes habe ich ein Berichtsprojekt mit denselben Pfadangaben
erstellt und einen Bericht reingepackt. Erstellt und bereitgestellt,
ohne Probleme. Der Bericht ist da und kann ich mitm Berichtsdesigner
öffen, solange ich als Admin auf demselben Server die Bibliothek öffne.
Mache ich das am Clientconputer mit einem BEnutzerkonto das volle REchte
auf die Bibliothek hat, kommt die Meldung das die DAtenqulle nicht
gefunden wurde und der SQL meldet einen ungültigen Anmeldeversuch von
NTAUTORITÄT\Netzwerk.
Wenn ich dann im Sharepoint die Inhaltstypen hinzufügen will um
Berechtigungen auf die Berichte zu vergeben, werden diese nicht angezeigt.
Was habe ich falsch gemacht, bzw. wo könnte der Fehler liegen, hat
jemand eine Idee?

Vielen Dank und Grüße
Tobias
 

Lesen sie die antworten

#1 Klaus Sobel [MS]
16/09/2008 - 15:00 | Warnen spam
Hallo Tobias,

ich denke da sind mehrere Probleme aufgetreten.

Zunàchst wàre zu überpüfen, ob in den Features der Site Collection in denen
die Site liegt, die Deine Document Library für Deine Berichte auch das
Reporting Feature
aktiviert ist.

Probier doch mal in der Datenquelle des Berichtes einen Domànenaccount zu
verwenden, der sicher Rechte auf die Datenbank hat und diesen fest zu
hinterlegen.

mit freundlichen Grüssen

Klaus Sobel

EMEA Developer Support

Troubleshooting in diesem Bereich ist leider keine einfache Sache und man
muss versuchen herauszufinden, in welchem Layer das Problem auftritt,





"Tobias Müller" wrote:

Hallo liebe NG,

ich habe versucht einen Berichtsserver im integrierten Sharepointmodus
zu installieren, aber leider werden die Inhaltstypen nicht erzeugt (bzw.
sie stehen auf jeden Fall nicht zur Verfügung). Das hat zur Folge, dass
ich keine Berichtigungen auf Berichtsmodellelemente vergeben kann.

Folgendes habe ich gemacht:

Auf einem Windows Server 2003 SP2 Sharepoint Services 3.0 mit Add-In für
Reporting Services installiert, SQL 2008 Reporting Services und BIDS.

Als erstes habe ich im Visual Studio-BIDS ein neues Berichtmodell
erstellt. Als Pfadangaben habe ich ein eine Sharepointbibliothek
genommen, die ich natürlich vorher schon erstellt hatte. Das Modell habe
ich dann erstellt und bereitgestellt. Keine Fehler! Achja die
Datenquelle verweist auf eine DB die auf einem 2. SQL 05 liegt.

Als nàchstes habe ich ein Berichtsprojekt mit denselben Pfadangaben
erstellt und einen Bericht reingepackt. Erstellt und bereitgestellt,
ohne Probleme. Der Bericht ist da und kann ich mitm Berichtsdesigner
öffen, solange ich als Admin auf demselben Server die Bibliothek öffne.
Mache ich das am Clientconputer mit einem BEnutzerkonto das volle REchte
auf die Bibliothek hat, kommt die Meldung das die DAtenqulle nicht
gefunden wurde und der SQL meldet einen ungültigen Anmeldeversuch von
NTAUTORITÄT\Netzwerk.
Wenn ich dann im Sharepoint die Inhaltstypen hinzufügen will um
Berechtigungen auf die Berichte zu vergeben, werden diese nicht angezeigt.
Was habe ich falsch gemacht, bzw. wo könnte der Fehler liegen, hat
jemand eine Idee?

Vielen Dank und Grüße
Tobias


Ähnliche fragen