REQ: Hilfe verschachtelte COUNTIF Function

27/02/2008 - 23:01 von TheBrainstorm | Report spam
Ein Hallo der versammelten Gruppe!

Wer kann mir bei folgendem Problem weiterhelfen:

Ich muss aus einer relativ grossen Tabelle Werte bzw. Eingaben abfragen.

In der Spalte <A> stehen Namen (die sind bereits vordeffiniert und àndern sich eigentlich nicht)

In den Spalten <B - F> ist <Ja> oder <Nein> eingetragen.

Auf einem extra Blatt soll jetzt die "Berechnung" durchgeführt werden.

In Spalte <A1> steht der Name.
In Spalte <B1 - F1> soll jetzt die Gesamtmenge der jeweiligen Spalten kommen und in
den Zellen <B2 - F2> die Summe der jeweiligen "Ja" Werte. Und entsprechend in
den Zellen <C3 - F3> die Summen der Jeweiligen "Nein" Werte.

Inzwischen bekommen ich ja mit der COUNTIF Funktion die Gesamtsumme in die Felder >B2 - F2< =COUNTIF(A1;"Meier")

Nur die verschachtelte COUNTIF bekomme ich nicht hin.
Es sollen die Menge der "Ja" aus Spalte >B< hinkommen, die der "Meier" aus Spalte >A< produziert hat.
Zum allgemeinen Verstàndnis anders herum. Wenn ich einen Filter auf die Spalte >A< "Meier" und die Spalte >B< "Ja" lege , dann die Ja's markiere, bekomme ich die richtige Antwort in der Statuszeile.
Und per Hand bei ca. 120 Abfragen macht das keinen Spass mehr.

Bitte um Eure Hilfe.
Danke im Voraus.

Aja, mein System. Win XP, Office 2003 + Office 2007 englisch

EuerTheBrainstorm Georg
 

Lesen sie die antworten

#1 Alexander Wolff
28/02/2008 - 09:27 | Warnen spam
In der Spalte <A> stehen Namen (die sind bereits vordeffiniert und àndern
sich eigentlich nicht)
In den Spalten <B - F> ist <Ja> oder <Nein> eingetragen.



OK.

Auf einem extra Blatt soll jetzt die "Berechnung" durchgeführt werden.

In Spalte <A1> steht der Name.
In Spalte <B1 - F1> soll jetzt die Gesamtmenge der jeweiligen Spalten
kommen und in



Was meinst Du damit? Das sind 5 Spalten.

den Zellen <B2 - F2> die Summe der jeweiligen "Ja" Werte. Und entsprechend
in
den Zellen <C3 - F3> die Summen der Jeweiligen "Nein" Werte.



Bist Du sicher, dass die Bereiche stimmen? Zeile 2 hat 5 Zellen, Zeile 3 nur
4.

Inzwischen bekommen ich ja mit der COUNTIF Funktion die Gesamtsumme in die
Felder >B2 - F2< =COUNTIF(A1;"Meier")



Du wendest die Funktion falsch an. Lies die Hilfe!

Nur die verschachtelte COUNTIF bekomme ich nicht hin.



Was meinst Du mit Verschachtelung?

Es sollen die Menge der "Ja" aus Spalte >B< hinkommen, die der "Meier" aus
Spalte >A< produziert hat.



Aha: Nicht "Verschachtelung", sondern das Anwenden mehrerer Bedingungen.
=SUMMENPRODUKT((A1:A100="Meier")*(B1:B100="Ja)) z.B.

Moin+Gruss Alexander - MVP für MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen