Requery funktioniert als "admin" und als Benutzer nicht

17/04/2008 - 13:42 von Peter Knopf | Report spam
Folgendes Problem:
Ich habe eine Access 2003 DB. In der ist ein Formular mit
Registersteuerelement und in dem Registerstuerelement ist ein Unterformular.
Hinter dem Unterformular hàngt eine Abfrage. Funktioniert soweit alles
wunderbar.
Jetzt gibt es im Formular einen Schalter der via VBA bei jedem Druck das
Unterformular das im Registersteuerelement drin ist aktualisieren soll, und
zwar so:

Forms(0)!REP_Wochenplan_Unterformular.Requery

Gehts soweit auch. ABER:
Nur solange ich meine DB mit der "Access Spezialtaste" (Shift) öffne und so
quasi Admin der DB bin.
Bei einem normalen Benutzer der einfach die DB öffnet passiert beim Klick
auf den entsprechenden Schalter einfach gar nichts.
Nicht einmal eine Fehlermeldung.

Tips?

Danke,
Peter
 

Lesen sie die antworten

#1 Karl Donaubauer
17/04/2008 - 13:52 | Warnen spam
Peter Knopf wrote:
Ich habe eine Access 2003 DB. In der ist ein Formular mit
Registersteuerelement und in dem Registerstuerelement ist ein
Unterformular. Hinter dem Unterformular hàngt eine Abfrage.
Funktioniert soweit alles wunderbar.
Jetzt gibt es im Formular einen Schalter der via VBA bei jedem Druck
das Unterformular das im Registersteuerelement drin ist aktualisieren
soll, und zwar so:

Forms(0)!REP_Wochenplan_Unterformular.Requery

Gehts soweit auch. ABER:
Nur solange ich meine DB mit der "Access Spezialtaste" (Shift) öffne
und so quasi Admin der DB bin.
Bei einem normalen Benutzer der einfach die DB öffnet passiert beim
Klick auf den entsprechenden Schalter einfach gar nichts.
Nicht einmal eine Fehlermeldung.

Tips?



Teste mal, ob in die Ereignisprozedur gesprungen wird,
indem du ganz am Anfang eine MsgBox setzt.

Shift-Taste oder nicht hat mit "Admin" oder "Benutzer" nichts
zu tun. Da geht's eher darum, ob irgendwelche Codes ausgeführt
werden, die du in einem Autoexec oder Startformular drin hast.
Wenn dem so ist, dann öffne mal mit Shift-Taste und führe dann
das Autoexec aus und/oder öffne das Startformular. Hast du
dann gleichen Defekt?

HTH
Karl
********* Ich beantworte keine Access-Fragen per Email. *********
Access-FAQ: http://www.donkarl.com
SQL Server-Entwickler-Konferenz: www.donkarl.com/?SEK
Nürnberg 19./20.4.2008

Ähnliche fragen