Forums Neueste Beiträge
 

Routing Probleme PPTP VPN

18/03/2008 - 00:20 von Nils Schneider | Report spam
Hallo Leute,

ich bin gerade dabei auf meinem Server (OpenSUSE 10) ein PPTP
einzurichten, um ab und an mal mit meinem Kumpel ein paar LAN-Spiele
übers Internet daddeln zu können (beide Clients sind WinXP Maschinen).

Eigentlich bin ich mit der Einrichtung auch relativ weit gekommen, wir
können beide eine Verbindung aufbauen. Soweit so gut.

Allerdings können wir uns gegenseitig keine Pings zuschicken, bekommen
immer einen Timeout. Den Server können wir allerdings ohne Problem
anpingen und auch der Server kann die Clients pingen. Nur die Clients
untereinander funktionieren leider nicht.

Ich bin mir nicht ganz sicher wie ich für die Netze nun das Routing
legen muss. Bin eigentlich nicht so der Netzwerkspezi.

Folgende Eckdaten haben wir momentan:

- Server steht im Internet und auf ihm làuft der pptp-Server (nur dann
wenn wir ihn brauchen)

- Nachdem wir beide erfolgreich verbunden sind ergeben sich folgende
IP-Adressen:

- Server@suse 192.168.81.1
- Ich@XP 192.168.81.81 - Ethernet-Adapter ppp0
- Er@XP 192.168.81.64 - Ethernet-Adapter ppp1

- IP-Forwarding habe ich aktiviert

Wie gesagt, Ping zum Server klappt auf beiden Seiten, bloß von Client zu
Client gehts nicht. Ich bin mir sicher ich muss nur noch das passende
Routing eintragen, leider weiss ich nicht was genau ich da eintragen
muss. Irgendwie schaut das für mich als Laien garnicht so schlecht aus:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
81.169.128.1 0.0.0.0 255.255.255.255 UH 0 0 0 eth0
192.168.81.81 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
192.168.81.64 0.0.0.0 255.255.255.255 UH 0 0 0 ppp1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 81.169.128.1 0.0.0.0 UG 0 0 0 eth0

Evtl hat jemand einen Tipp für mich?

Danke,

Nils
 

Lesen sie die antworten

#1 Henning Paul
18/03/2008 - 10:11 | Warnen spam
Nils Schneider schrieb:

Hallo Leute,

ich bin gerade dabei auf meinem Server (OpenSUSE 10) ein PPTP
einzurichten, um ab und an mal mit meinem Kumpel ein paar LAN-Spiele
übers Internet daddeln zu können (beide Clients sind WinXP Maschinen).

Eigentlich bin ich mit der Einrichtung auch relativ weit gekommen, wir
können beide eine Verbindung aufbauen. Soweit so gut.

Allerdings können wir uns gegenseitig keine Pings zuschicken, bekommen
immer einen Timeout. Den Server können wir allerdings ohne Problem
anpingen und auch der Server kann die Clients pingen. Nur die Clients
untereinander funktionieren leider nicht.

Ich bin mir nicht ganz sicher wie ich für die Netze nun das Routing
legen muss. Bin eigentlich nicht so der Netzwerkspezi.

Folgende Eckdaten haben wir momentan:

- Server steht im Internet und auf ihm làuft der pptp-Server (nur dann
wenn wir ihn brauchen)

- Nachdem wir beide erfolgreich verbunden sind ergeben sich folgende
IP-Adressen:

- 192.168.81.1
- 192.168.81.81 - Ethernet-Adapter ppp0
- 192.168.81.64 - Ethernet-Adapter ppp1

- IP-Forwarding habe ich aktiviert

Wie gesagt, Ping zum Server klappt auf beiden Seiten, bloß von Client
zu Client gehts nicht. Ich bin mir sicher ich muss nur noch das
passende Routing eintragen, leider weiss ich nicht was genau ich da
eintragen muss. Irgendwie schaut das für mich als Laien garnicht so
schlecht aus:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use
Iface
81.169.128.1 0.0.0.0 255.255.255.255 UH 0 0 0 eth0
192.168.81.81 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
192.168.81.64 0.0.0.0 255.255.255.255 UH 0 0 0 ppp1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 81.169.128.1 0.0.0.0 UG 0 0 0 eth0

Evtl hat jemand einen Tipp für mich?



Wie sehen denn die Routen auf den XP-Clients aus? Zeigen die als
Host-Route auf den Server oder als Subnetz-Route? Ändert sich was, wenn
man die Route auf den jeweils anderen Client manuell anlegt?

Gruß
Henning
henning paul home: http://home.arcor.de/henning.paul
PM: , ICQ: 111044613

Ähnliche fragen