RPC over HTTPS Verbindungsabbrüche

09/02/2009 - 13:05 von Christian | Report spam
Hallo, zusammen!

Es existieren zwar schon einige Threads zum Thema, jedoch passt mutmaßlich
keiner 100%ig zu meinem Problem. Hier das Szenario:

Wir verwenden Windows Server 2003 R2 SP2 mit Exchange Server 2003 SP2.

Drei unserer Mitarbeiter an einem Remotestandort (kein VPN, sondern
lediglich ein DSL-Anschluss + DSL-Router, kabelgebundenes Netzwerk, Vista
SP1, Outlook 2007) verbinden sich per RPC-over-HTTPS mit unserem Exchange
Server.

Dies funktioniert morgens durchaus, jedoch bricht dann zu unterschiedlichen
Zeitpunkten (mal um 10, mal um 12) die Verbindung ab (wohlgemerkt Internet
funtktioniert noch) und kann u. U. bis zum nàchsten Arbeitstag nicht mehr
hergestellt werden. Und zwar bei allen 3 MA gleichzeitig, was natürlich auf
den ersten Blick auf Netzwerkprobleme am Remote-Standort hindeutet. Der
Netgear-DSL-Router verràt in seinen Logs jedoch auch, dass die
Internetverbindung den ganzen Tag besteht und auch die IP-Adresse vom
Provider erst nachts erneuert wird. Ruft man auf den Notebooks der MA Outlook
mit dem Schalter /rpcdiag auf, so werden Eintràge angezeigt à la "HTTPS" und
"Verbindungsversuch", jedoch keinerlei Fehler oder weitere Details. Auf
unserem Exchange-Server ist im Security-Ereignisprotokoll nachvollziehbar,
dass nach dem Zeitpunkt des Abbruchs der RPC-Verbindung nur noch Ereignisse
der Kennung 680 (Anmeldversuch von: MICROSOFT_AUTHENTICATION_PACKAGE_V1_0),
nicht jedoch wie vorher auch Ereignisse 540 (Erfolgreiche Anmeldung) sowie
538 (Abmeldung) vorhanden sind.

OWA geht dann übrigens auch nicht mehr (Genaue Fehlermeldung muss ich noch
erfragen, jedoch kam keinerlei Zertifikatswarnung).

Kann die Konstellation von Vista und Office 2007 im Zusammenspiel mit
Exchange Server 2003 hier Probleme verursachen?

Vielen Dank vorab!

MFG
Christian
 

Lesen sie die antworten

#1 Steinsdorfer Walter [MVP Exchange Server]
09/02/2009 - 13:14 | Warnen spam
Hallo Christian,

Es existieren zwar schon einige Threads zum Thema, jedoch passt mutmaßlich
keiner 100%ig zu meinem Problem. Hier das Szenario:

Wir verwenden Windows Server 2003 R2 SP2 mit Exchange Server 2003 SP2.

Drei unserer Mitarbeiter an einem Remotestandort (kein VPN, sondern
lediglich ein DSL-Anschluss + DSL-Router, kabelgebundenes Netzwerk, Vista
SP1, Outlook 2007) verbinden sich per RPC-over-HTTPS mit unserem Exchange
Server.

Dies funktioniert morgens durchaus, jedoch bricht dann zu
unterschiedlichen
Zeitpunkten (mal um 10, mal um 12) die Verbindung ab (wohlgemerkt Internet
funtktioniert noch) und kann u. U. bis zum nàchsten Arbeitstag nicht mehr
hergestellt werden. Und zwar bei allen 3 MA gleichzeitig, was natürlich
auf
den ersten Blick auf Netzwerkprobleme am Remote-Standort hindeutet. Der
Netgear-DSL-Router verràt in seinen Logs jedoch auch, dass die
Internetverbindung den ganzen Tag besteht und auch die IP-Adresse vom
Provider erst nachts erneuert wird. Ruft man auf den Notebooks der MA
Outlook
mit dem Schalter /rpcdiag auf, so werden Eintràge angezeigt à la "HTTPS"
und
"Verbindungsversuch", jedoch keinerlei Fehler oder weitere Details. Auf
unserem Exchange-Server ist im Security-Ereignisprotokoll nachvollziehbar,
dass nach dem Zeitpunkt des Abbruchs der RPC-Verbindung nur noch
Ereignisse
der Kennung 680 (Anmeldversuch von:
MICROSOFT_AUTHENTICATION_PACKAGE_V1_0),
nicht jedoch wie vorher auch Ereignisse 540 (Erfolgreiche Anmeldung) sowie
538 (Abmeldung) vorhanden sind.

OWA geht dann übrigens auch nicht mehr (Genaue Fehlermeldung muss ich noch
erfragen, jedoch kam keinerlei Zertifikatswarnung).

Kann die Konstellation von Vista und Office 2007 im Zusammenspiel mit
Exchange Server 2003 hier Probleme verursachen?



es gab mal ein Problem mit Windows Vista und OE / Windows Mail. Das sollte
aber mit Vista Sp1 behoben sein. Welche Firewalleinstellungen sind denn an,
bzw. was wird denn als Tunnelendpunkt benutzt? Direkt der Exchange?

Viele Grüsse aus München

Walter Steinsdorfer
MVP Exchange Server
www.exusg.de
http://msmvps.com/blogs/wstein

Ähnliche fragen