Rpc over htts, zertifikate, outlook

29/01/2008 - 16:53 von Andreas | Report spam
Hallo,

ich beschàftige mich noch nicht all zulange mit dem Thema
ich weis das dieses Thema hier schon mehrfach behandelt wurde..
ich komm aber wirklich nicht mehr weiter..


Ausgangszustand:
Windows Server 2003 R2 Standart..
Exchange 2003 Standart
Single Server

mail verkehr über pop3 funktioniert ohne Problem
möchte nun die Exchange-Funktion für outlook nutzbar machen..

AD hat eine locale Domain (xxxxxx.loc)
Computername Server1.xxxxxx.loc
externe adresse Server1.xxxxxx.de
mails von bzw. für: nutzer@Server1.xxxxxx.de kommen an/gehen weg...

im DNS sind nur Server1.xxxxxx.loc eintràge (Forward und Reverse)
hat mir jemand so eingestellt

bei der Nutzung von OWA kommt immer die Meldung
-
Es besteht ein Problem mit dem Sicherheitszertifikat der Website.
Das Sicherheitszertifikat dieser Website wurde für eine andere Adresse der
Website ausgestellt.
Die Sicherheitszertifikatprobleme deuten eventuell auf den Versuch hin, Sie
auszutricksen bzw. Daten die Sie an den Server gesendet haben abzufangen.
nach klicken: Sicherheitszertifikat akzeptieren (Laden der Seite fortsetzen)
kommt die Nutzer/Passwort Abfrage und alles geht


wollte nun Outlook konfigurieren (RPC over HTTPS)

bei xp bricht es immer an dem punkt wo der namen aufgelöst werden sollte ab..
aber bei vista kommt die Meldung:
Es liegt ein Problem mit dem Sicherheitszertifikat des Proxyservers vor. Der
Name des Sicherheitszertifikats ist Ungültig oder entspricht nicht dem Namen
der Zielwebsite Server1.xxxxxx.de

Von Outlook kann keine Verbindung mit dem Proxyserver hergestellt werden
-
ist klar Outlook klick ja nicht von selber drauf: Sicherheitszertifikat
akzeptieren und weitermachen..
die ssl Serverzertifikate sollten doch im IE unter Vertrauenswürdige
Stammzertifikat eingetragen sein, damit die Fehlermeldung nicht kommt!

in den Proxyeinstellungen von Outlook steht die Server1.xxxxxx.de Domain
(Verbindung müsste doch klappen)

bei der erzeugung der einzelnen Sicherheitszertifikat wurde immer
Server1.xxxxxx.loc eingetragen (keine *.de...)

ich habe den Verdacht das es daran liegt..

ich hatte nun die die 3 zertifikate!
root (IID-M-> Standartwebseite->Verzeichnissicherheit->Serverzertifikat)
Webserver und Domainencontroller (Zertifizierungsstelle(Local)->Ausgestellte
Zertifikate)
exportiert und beim Clienten installiert..
Sicherheitsmeldung (Sicherheitszertifikat nicht ok) kommt immer noch bei OWA
und RPC über IE Anfragen

das root-zertifikat liegt unter Vertrauenswürdige Stammzertifikat
aber die anderen beiden beim Clienten unter (andere Personen).. ???
(hab aber bei der installation dieser beiden als Zeilort: Vertrauenswürdige
Stammzertifikat)

meiner ansicht an, liegt es an der local und de Domain

im einem anderen forum hatte ich gelesen das ich einfach den primaren
DNS-Suffix auf Server1.xxxxxx.de selzen soll und den Domainen name auf
Server1.xxxxxx.loc

ich habe aber leider ahnung wie das gehen sollte?
Oder dieses Problem losen sollte?

noch ne Frage:
sind die Vaildports so Ok? (Unter den RPCProxy Einstellungen)
Server1:6001-6002;Server1.xxxxxx.loc:6001-6002;Server1.xxxxxx.de:6001-6002;Server1:6004;Server1.xxxxxx.loc:6004;Server1.xxxxxx.de:6004

Ich hoffe, dass mir jemand helfen kann

Andreas
 

Lesen sie die antworten

#1 Marc Jochems [MVP]
29/01/2008 - 17:09 | Warnen spam
Hallo Andreas,

bei der Nutzung von OWA kommt immer die Meldung
-
Es besteht ein Problem mit dem Sicherheitszertifikat der Website.
Das Sicherheitszertifikat dieser Website wurde für eine andere Adresse
der
Website ausgestellt.
Die Sicherheitszertifikatprobleme deuten eventuell auf den Versuch
hin, Sie
auszutricksen bzw. Daten die Sie an den Server gesendet haben
abzufangen.
nach klicken: Sicherheitszertifikat akzeptieren (Laden der Seite
fortsetzen)
kommt die Nutzer/Passwort Abfrage und alles geht



Solange das Zertifikat nicht ohne Fehlermeldung angenommen wird, kannst
du das mit RPC over HTTPS vergessen. Outlook gibt dir nicht die
Möglichkeit diese Fehlermeldung weg zu klicken und daher wird es nicht
gehen. Beheb den Fehler mit dem Zertifikat und RPC wird auch
funktionieren.


Grüße

Marc Jochems

Ähnliche fragen