rubygems installiert falsche Version?

19/06/2009 - 20:18 von Thomas Preymesser | Report spam
Hallo,

kann mir jemand erklàren, warum gem versucht, gerade diese Version zu
installieren, obwohl es ein paar aktuellere Version davon gibt? Und
auch wenn ich mit '--version 1.3.5' explizit angebe, daß die neueste
Version installiert werden soll, wird trotzdem 1.0.2 installiert.

-Thomas

$ gem query --remote |grep roo
roo (1.3.5)

$ sudo gem update roo
Updating installed gems
Updating roo
Successfully installed roo-1.0.2
Gems updated: roo
Installing ri documentation for roo-1.0.2...
Updating ri class cache with 7839 classes...
Installing RDoc documentation for roo-1.0.2...
ERROR: While executing gem ... (NoMethodError)
undefined method `each' for #<String:0xea4eadc>

$ gem env
RubyGems Environment:
- RUBYGEMS VERSION: 1.3.4
- RUBY VERSION: 1.9.2 (2009-06-18 patchlevel -1) [i686-linux]
- INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/1.9.1
- RUBY EXECUTABLE: /usr/local/bin/ruby
- EXECUTABLE DIRECTORY: /usr/local/bin
- RUBYGEMS PLATFORMS:
- ruby
- x86-linux
- GEM PATHS:
- /usr/local/lib/ruby/gems/1.9.1
- /usr/lib/ruby/gems/1.8
- GEM CONFIGURATION:
- :update_sources => true
- :verbose => true
- :benchmark => false
- :backtrace => false
- :bulk_threshold => 1000
- REMOTE SOURCES:
- http://gems.rubyforge.org/
 

Lesen sie die antworten

#1 Thomas Preymesser
20/06/2009 - 13:57 | Warnen spam
... seltsamerweise funktioniert es jetzt wieder

-Thomas

Ähnliche fragen