Rundungsproblem

29/05/2008 - 14:53 von Michael | Report spam
Hallo NG,
ich muss für eine Tarifberechnung eine eigenstàndige Rundungsregel
beachten:
Werte mit den Nachkommastellen 0,01 bis 0,29 werden auf 0,00 gerundet
Werte mit den Nachkommastellen 0,30 bis 0,73 werden auf 0,50 gerundet
und Werte mit den Nachkommastellen 0,74 bis 0,99 werden auf den
nàchst
höheren vollen Zahlenwert gerundet (1,00)
Welche Formel kann ich bei diesem Spezialfall anwenden, wenn der Wert
der
zu runden ist, in A1 steht?

Beispiele: 2,18 soll 2,00 werden; 2,43 genauso 2,50 werden wie 2,71;
und 2,93 soll 3,00 werden.

Vielen Dank für eure Hilfe
Grüße aus dem sonnigen H@@n in Rheinland
Michael
 

Lesen sie die antworten

#1 Thomas Kühn
29/05/2008 - 15:50 | Warnen spam
Hallo Michael,


Werte mit den Nachkommastellen 0,01 bis 0,29 werden auf 0,00 gerundet
Werte mit den Nachkommastellen 0,30 bis 0,73 werden auf 0,50 gerundet
und Werte mit den Nachkommastellen 0,74 bis 0,99 werden auf den
nàchst
höheren vollen Zahlenwert gerundet (1,00)
Welche Formel kann ich bei diesem Spezialfall anwenden, wenn der Wert
der
zu runden ist, in A1 steht?

Beispiele: 2,18 soll 2,00 werden; 2,43 genauso 2,50 werden wie 2,71;
und 2,93 soll 3,00 werden.



=WENN(ABS(A1-GANZZAHL(A1))<0,30
;GANZZAHL(A1)
;WENN(ABS(A1-GANZZAHL(A1))<0,74
;GANZZAHL(A1)+0,5
;GANZZAHL(A1+0,3)
)
)


Gruß Thomas

http://www.thomas-kuehn.de

Ähnliche fragen