Samba 3.4.0: kein Zugriff (mehr) von Win9x?

01/02/2010 - 14:20 von Ansgar Strickerschmidt | Report spam
Hallo NG,

habe hier einen neuen kleinen Server mit Ubuntu 9.10 Server aufgesetzt.
Dieser bringt Samba 3.4.0 (in einer Ubuntu-Geschmacksrichtung) mit.
Habe einige Freigaben drauf eingerichtet.
Von WinXP-Clients kann ich darauf zugreifen.
Von Win98SE-Clients aus nicht. Dort kommt beim Öffnen des Servers: "Der
Typ des lokalen Geràts stimmt nicht mit dem der Netzwerkressource überein."
Bin da etwas ratlos. Tante Gugel spuckt zu dieser Fehlermeldung auch
nichts recht Erhellendes aus.
Wo muss ich drehen?
Ist jetzt nicht so brisant, da ich ja von XP-Rechnern aus (und auch per
SSH) auf die Maschine zugreifen kann. Wàre halt nur schick, wenn's auch
von den alten Win98-Clients (wieder) ginge.
Ein ganz àhnlich aufgesetzter Rechner unter Ubuntu 8.04.3 LTS fuktioniert
übrigens auch mit Win98SE klaglos; dort ist Samba 3.0.28a im Einsatz.

Ich habe gehört, Samba 3.4.0 soll ziemlich schlecht sein, und ein Upgrade
auf 3.4.4 oder 3.4.5 dringend ratsam. Behebt dies das Problem? Dann würde
ich mir sogar den Sourcecode holen und ein Kompilieren wagen, da für
Ubuntu meines Wissens noch kein fertiges Paket verfügbar ist. Gibt es da
bei Ubuntu 9.10 spezielle Maßnahmen, die zu beachten sind, oder
Hindernisse, die das Kompilieren generell verhindern?

Ansgar

*** Musik! ***
 

Lesen sie die antworten

#1 Helmut
01/02/2010 - 14:56 | Warnen spam
Hallo, Ansgar,

Du meintest am 01.02.10:

habe hier einen neuen kleinen Server mit Ubuntu 9.10 Server
aufgesetzt. Dieser bringt Samba 3.4.0 (in einer
Ubuntu-Geschmacksrichtung) mit. Habe einige Freigaben drauf
eingerichtet. Von WinXP-Clients kann ich darauf zugreifen.
Von Win98SE-Clients aus nicht. Dort kommt beim Öffnen des Servers:
"Der Typ des lokalen Geràts stimmt nicht mit dem der
Netzwerkressource überein."



Ich habe gehört, Samba 3.4.0 soll ziemlich schlecht sein, und ein
Upgrade auf 3.4.4 oder 3.4.5 dringend ratsam. Behebt dies das
Problem?



Vielleicht.

Quellen: http://samba.sernet.de/

Am Rande:

Jeremy Allison in der Samba-Mailingliste:

Zitat ein --

Ok, here's the deal. If you have 64-bit Windows clients at the
moment you need to be using 3.3.10, not anything later. If you're
using 32-bit Windows clients, you can use 3.4.5 or later.

The reason (and Guenther can correct me if I'm wrong), is
that in 3.4.x we changed from the hand-marshalled SPOOLSS RPC
we used in 3.3.x, which was mostly correct after being worked
on for many years, to pidl-generated SPOOLSS RPC directly from
the idl files. Now our idl files are correct, but it turns
out that the Windows idl parser for SPOOLSS is itself custom,
and won't accept the normally marshalled RPC packets that
the pidl-generated code creates.

Zitat aus --


Viele Gruesse
Helmut

"Ubuntu" - an African word, meaning "Slackware is too hard for me".

Ähnliche fragen