Samba auf Debian Testing

09/12/2014 - 22:00 von Matthias Taube | Report spam
Ich versuche ein Samba auf Debian Testing aufzusetzen.

Leider ist ein Zugriff nur in ca. 50% der Fàlle erfolgreich.
meist erfolgt beim ersten Zugriff:

mati@zeus:~$ smbclient -L BALDER-TEST
Enter mati's password:
session setup failed: NT_STATUS_UNSUCCESSFUL




beim zweiten Zugriff (gleicher Nutzer, gleiches Password) funktioniert
es dann.

Der Log auf dem Server zeigt beim gescheiterten Zugriff:

[2014/12/09 21:36:53.302707, 2] ../source3/auth/auth.c:278(auth_check_ntlm_password)
check_ntlm_password: authentication for user [mati] -> [mati] -> [mati] succeeded
[2014/12/09 21:36:53.310973, 1] ../source3/auth/token_util.c:430(add_local_groups)
SID S-1-5-21-1496718785-1936926132-3287012785-1000 -> getpwuid(4294967295) failed
[2014/12/09 21:36:53.313398, 1] ../source3/smbd/sesssetup.c:276(reply_sesssetup_and_X_spnego)
Failed to generate session_info (user and group token) for session setup: NT_STATUS_UNSUCCESSFUL



Beim funktionierenden Zugriff:

[2014/12/09 21:37:05.543339, 2] ../source3/auth/auth.c:278(auth_check_ntlm_password)
check_ntlm_password: authentication for user [mati] -> [mati] -> [mati] succeeded
[2014/12/09 21:37:05.637935, 2] ../source3/smbd/reply.c:592(reply_special)
netbios connect: name1ºLDER-TEST 0x20 name2=ZEUS 0x0
[2014/12/09 21:37:05.641139, 2] ../source3/smbd/reply.c:633(reply_special)
netbios connect: local=balder-test remote=zeus, name type = 0



Es scheint offenbar am "getpwuid(4294967295) failed" zu liegen. Kann mir
jemand einen Hinweis geben, woran das liegen könnte dass dies immer erst
beim zweiten Zugriff klappt?

Der Server ist mit:

workgroup = HAUS
interfaces = eth0
server role = standalone server
obey pam restrictions = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\s*\spassword:* %n *Retype\snew\s*\spassword:* %n *password\supdated\ssuccessfully* .
unix password sync = Yes
local master = No
wins server = 192.168.1.2
idmap config * : backend = tdb



eingerichtet.

mfg
Matthias



Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: https://lists.debian.org/m67ngu$cu7$1@ger.gmane.org
 

Lesen sie die antworten

#1 Paul Muster
09/12/2014 - 22:30 | Warnen spam
On 09.12.2014 21:53, Matthias Taube wrote:
Ich versuche ein Samba auf Debian Testing aufzusetzen.

Leider ist ein Zugriff nur in ca. 50% der Fàlle erfolgreich.
meist erfolgt beim ersten Zugriff:

beim zweiten Zugriff (gleicher Nutzer, gleiches Password) funktioniert
es dann.

Es scheint offenbar am "getpwuid(4294967295) failed" zu liegen. Kann mir
jemand einen Hinweis geben, woran das liegen könnte dass dies immer erst
beim zweiten Zugriff klappt?



Schau mal, ob ein nscd oder ein unscd làuft. Für mich fühlt sich das,
was du beschreibst, nach Schrott im Cache oder einem leeren Cache an.


mfG Paul



Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: https://lists.debian.org/

Ähnliche fragen