samba muckt nach upgrade von lenny auf squeeze

31/03/2011 - 09:43 von Joachim Hartmann | Report spam
Hallo Zusammen!
Der Upgrade von lenny auf squeeze at grundsàtzlich problemlos
geklappt!
- Die Fehlermeldungen von dpkg-reconfigure sysv-rc kann man wohl
Erstmal übergehen.
- Munin will nicht so richtig, ist aber eine Baustelle für spàter.
- Aber Samba macht mir Sorgen!

Wegen der individuellen Einstellungen habe ich meine alte smb.conf
übernommen (testparm findet auch keinen Fehler)

#[global]
workgroup = MyGroup
guest account = nobody
netbios name = Samba
load printers = no
server string = c't-Server (Samba %v)
invalid users = root
os level = 20
domain master = no
null passwords = yes
encrypt passwords = true
wins support = true
domain master = yes

[Ilse]
comment = Netz-Laufwerk fuer Ilse
path = /srv/rumba/ilse
read list = @rumba
write list = @breuker
force directory mode = 0770
force group = rumba
force create mode = 0770
create mode = 0770
directory mode = 0770

[Jo]
read list = @rumba
write list = @rumba
path = /srv/rumba/jo
force directory mode = 0770
force group = rumba
force create mode = 0770
force user = jo
comment = Netz-Laufwerk fuer Jo
create mode = 0770
directory mode = 0770
#
Unter WinXP wird auch "c't Server (Samba 3.5.6) (Samba)" angezeigt.
Der Zugriff wird bei der Nutzer-/Kennwortabfrage jedoch verweigert.
Der User jo ist unter Debian (auch in der /etc/passwd) vorhanden.
smbpasswd kennt den User jedoch nicht obwohl in der
/etc/samba/smbpasswd vorhanden. Die Optionen -x -a melden den Fehler
"Failed to find entry for user jo"
Einer eine Idee?
Gruß aus der Stadt CeBIT
Jochen
 

Lesen sie die antworten

#1 Helmut
31/03/2011 - 10:41 | Warnen spam
Hallo, Joachim,

Du meintest am 31.03.11:

Der Upgrade von lenny auf squeeze at grundsàtzlich problemlos
geklappt!


- Aber Samba macht mir Sorgen!


Unter WinXP wird auch "c't Server (Samba 3.5.6) (Samba)" angezeigt.
Der Zugriff wird bei der Nutzer-/Kennwortabfrage jedoch verweigert.
Der User jo ist unter Debian (auch in der /etc/passwd) vorhanden.
smbpasswd kennt den User jedoch nicht obwohl in der
/etc/samba/smbpasswd vorhanden. Die Optionen -x -a melden den Fehler
"Failed to find entry for user jo"



"smbpasswd" dürfte nicht mehr die vor-eingestellte Datenbank sein. Wurde
bei Samba vor ganz vielen Monaten auf "passdb.tdb" umgestellt.

testparm -sv 2>/dev/null | grep passdb

sollte die jetzige Vor-Einstellung zeigen.

Viele Gruesse
Helmut

"Ubuntu" - an African word, meaning "Slackware is too hard for me".

Ähnliche fragen