SATA Hot Swap - doch nicht so dolle?

27/04/2008 - 10:44 von Christian Herenz | Report spam
Hallo,

(Achtung: etwas Hardwarelastig, aber Suse bezogene Frage am Schluss)

Ich habe mir einen SATA-Wechselrahmen gekauft und darin eine Platte eingebaut,
auf der, so plane ich, ca. 1 mal die Woche mit rsync ein inkrementelles Backup
erfolgt.

Nach dem Einbau habe ich ein Verzeichnis /backup (ganz oben in der Wurzel)
angelegt und mit YAST das Laufwerk formattiert und eingebunden. Backup und so
làuft super... Obwohl..

3 Dinge nerven mich ein bisschen:

1) Dieser eine Chip auf dem Mainboard unter dem die SATA Stecker sind wird jetzt
viel zu heiß. Da könnte man Spiegeleier drauf braten. Wenn ich meinen Rechner
zumache gibt es dann nàmlich, sobald man kontinuierlich auf größere Datenmengen
zugreift folgenden Fehler: (/var/log/messages/):

Apr 24 18:46:19 KnusperStation kernel: ata1.00: exception Emask 0x0 SAct 0x0
SErr 0x180000 action 0x2 frozen
Apr 24 18:46:19 KnusperStation kernel: ata1.00: cmd
35/00:00:57:72:00/00:04:00:00:00/e0 tag 0 cdb 0x0 data 524288 out
Apr 24 18:46:19 KnusperStation kernel: res
40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)
Apr 24 18:46:26 KnusperStation kernel: ata1: port is slow to respond, please be
patient (Status 0xd0)
Apr 24 18:46:49 KnusperStation kernel: ata1: port failed to respond (30 secs,
Status 0xd0)
Apr 24 18:46:49 KnusperStation kernel: ata1: soft resetting port


Das passiert wie gesagt nicht, wenn der Rechner offen ist... Also eindeutig ein
thermisches Problem. Aber nun kann man ja nicht _einfach_ auf diesen Chip da
einen neuen Kühlkörper setzen... Also, zumindest kann ich das nicht...

2) Zu allem Überfluss eines thermischen Problems im inneren des Rechners macht
der Wechselrahmen auch gut làrm, weil ein Minilüfter ungeregelt mit 1000
Umdrehungen meine Festplatte kühlt.

3) Aus 1) und 2) dachte ich mir... Naja, dann schalte ich den Rahmen (der hat
einen Schalter) eben nur an, wenn ich ein Backup mache. Nur startet openSUSE
nicht, wenn die Platte ausgeschaltet ist, obwohl ich schon eingestellt habe, das
die Platte nicht beim Start gemountet werden soll. Das System möchte beim Start
wohl immer ein fsck auf der Platte machen, die findet er nicht und dann wird man
auf einen maintaince prompt geschleudert. Ausschalten im Betrieb geht auch
nicht (nach umount, natürlich), denn dann làsst sich der Rechner nicht mehr
ordnungsgemàß runterfahren, hàngt dann an dem Punkt "System Will be halted
immediatly", auf der Busybox-Shell sieht man aber noch wie er auf die inzwischen
ausgeschaltete Festplatte wartet.

Ich bin etwas abgenervt von dem Problem. Also, wenn jemand hilfreiche Hinweise
hat...

Gruß,
Christian
 

Lesen sie die antworten

#1 Christian Herenz
27/04/2008 - 11:03 | Warnen spam
Also,
um das noch meinem vorherigen Post vielleicht hinzuzufügen Die
Hardware-Probleme krieg ich in den Griff... Mich würde halt wirklich reizen, die
Platte ein und ausschalten zu können (Hot Swap eben), dabei sollte aber der
Computer natürlich entweder ordentlich starten oder ordentlich ausgehen...
Gruß,
Christian

Ähnliche fragen