Schnittmenge und Summewenn liefert falsches Ergebnis?

29/11/2007 - 12:14 von julia.hess | Report spam
Hallo!

Ich möchte Elemente einer Schnittmenge dann summieren, wenn sie in der
gleichen Zeile stehen, wie ein Kriterium, das ich mit Summewenn
abfrage. Leider ist das Ergebnis falsch.

Kann es sein, dass Excel Summewenn auf Schnittmengen nicht anwenden
kann?
 

Lesen sie die antworten

#1 Alexander Wolff
29/11/2007 - 14:59 | Warnen spam
Die Tastatur von wurde wie folgt gedrückt:
Ich möchte Elemente einer Schnittmenge dann summieren, wenn sie in der
gleichen Zeile stehen, wie ein Kriterium, das ich mit Summewenn
abfrage. Leider ist das Ergebnis falsch.

Kann es sein, dass Excel Summewenn auf Schnittmengen nicht anwenden
kann?



Ja, das ist tatsàchlich so. Für Schnittmengen nimmst Du

=SUMMENPRODUKT(--(A1:A9="a");--(B1:B9>5);B1:B9)

"a" und "5" sind Beispiele.

=SUMMEWENN ist (viel!) schneller, www.xxcl.de/0038.htm. Daher kannst Du auch
mit einer angehàngten Spalte arbeiten, die eine Formel wie folgt hat:

C1: =(A1="a")*(B1>5) runterkopieren

Du packst sozusagen die Bedingung für Schnittmenge (oder auch
Vereinigungsmenge) in eine Nebenspalte.
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen