Schrägstrich in Formel abfragen

27/02/2011 - 16:11 von smaenner | Report spam
Excel 2010

Ich sitze seit Tagen an einem Problem, dass mir fast nicht lösbar erscheint.

In einer Tabelle mit Laborergebnisse sind folgende Daten eingetragen:
0/64, 2/58, 5/93 etc. (jeder Wert in einer separaten Zelle)

Anforderung an die Tabelle: Das Ergebnis soll als Summe gerechnet
werden, also im Beispiel kommt 7/215 gesamt heraus. Dazu habe ich
folgende Lösung entwickelt:

1. Zahlen umwandeln in A1 mit Apstroph '0/64 etc.

2. Funktion in:

E1 =SUMME(LINKS(A1;1);LINKS(B1;1);LINKS(C1;1)) rechnet den linken Teil

F1 =SUMME(TEIL(A1;3;5);TEIL(B1;3;5);TEIL(C1;3;5)) rechnet den rechten Teil

H1 á&"/"&F1 verknüpft beide Teile zum Ergebnis

Das funktioniert einigermaßen, jetzt meine Probleme, die ich nicht lösen
konnte:

1. Die Formelkette wird immer lànger, d.h. ich muss bisher für jede
Zelle die Formel wiederholen, was bei langen Zeilen nicht funktioniert.

2. Der linke Teil, àndert sich 0/64 in 10/64 etc., dann klappt =Links()
nicht mehr, da sich der Zàhlerwert auf 2 verschiebt. Leider liegen die
Zahlen in diesen unterschiedlichen Varianten in der Tabelle vor.

Meine Frage:

Gibt Excel eine Möglichkeit, den Slash / in einer Funktion abzufragen um
die Stellewerte dynamisch, d.h. mal mit 1 Stellenwert bzw. 2 oder mehr
Stellenwerten, abzufragen.

Für die Laborabrechnung wàre es eine große Hilfe, da ansonsten die
Zahlen mit dem Taschenrechner addiert werden müssen.

Evtl. wàre der Slash auch tauschbar in das Blankzeichen (Code 10). Auf
jeden Fall nicht ganz einfach.

Grüße
 

Lesen sie die antworten

#1 {Boris}
27/02/2011 - 16:24 | Warnen spam
Hi,

On 27 Feb., 16:11, smaenner wrote:
Excel 2010

Ich sitze seit Tagen an einem Problem, dass mir fast nicht l sbar erscheint.

In einer Tabelle mit Laborergebnisse sind folgende Daten eingetragen:
0/64, 2/58, 5/93 etc. (jeder Wert in einer separaten Zelle)

Anforderung an die Tabelle: Das Ergebnis soll als Summe gerechnet
werden, also im Beispiel kommt 7/215 gesamt heraus. Dazu habe ich
folgende L sung entwickelt:

1. Zahlen umwandeln in A1 mit Apstroph '0/64 etc.

2. Funktion in:

E1 =SUMME(LINKS(A1;1);LINKS(B1;1);LINKS(C1;1)) rechnet den linken Teil

F1 =SUMME(TEIL(A1;3;5);TEIL(B1;3;5);TEIL(C1;3;5)) rechnet den rechten Teil

H1 á&"/"&F1 verkn pft beide Teile zum Ergebnis

Das funktioniert einigerma en, jetzt meine Probleme, die ich nicht l sen
konnte:

1. Die Formelkette wird immer l nger, d.h. ich muss bisher f r jede
Zelle die Formel wiederholen, was bei langen Zeilen nicht funktioniert.

2. Der linke Teil, ndert sich 0/64 in 10/64 etc., dann klappt =Links()
nicht mehr, da sich der Z hlerwert auf 2 verschiebt. Leider liegen die
Zahlen in diesen unterschiedlichen Varianten in der Tabelle vor.

Meine Frage:

Gibt Excel eine M glichkeit, den Slash / in einer Funktion abzufragen um
die Stellewerte dynamisch, d.h. mal mit 1 Stellenwert bzw. 2 oder mehr
Stellenwerten, abzufragen.

F r die Laborabrechnung w re es eine gro e Hilfe, da ansonsten die
Zahlen mit dem Taschenrechner addiert werden m ssen.

Evtl. w re der Slash auch tauschbar in das Blankzeichen (Code 10). Auf
jeden Fall nicht ganz einfach.

Gr



Die Eintràge stehen im Beispiel in A1, B1 und C1.
Die Summe der linken Zahlen:
=SUMMENPRODUKT((LINKS(A1:C1;FINDEN("/";A1:C1)-1))+0)

Und die der rechten:
=SUMMENPRODUKT((TEIL(A1:C1;FINDEN("/";A1:C1)+1;99)+0))

Grüße Boris

Ähnliche fragen