Forums Neueste Beiträge
 

Schrittmotor-Steuerung

03/11/2008 - 09:56 von sailcam | Report spam
Grüßt Euch,

ich habe hier einen Wegwerf-Scanner, der mal mechanisch blockiert hat
(Schlitten konnte sich nicht frei bewegen). Die Sinnhaftigkeit der
Reparatur dieses Agfa-Wegwerf-Scanners brauchen wir nicht zu
diskutieren.

Nachdem der Defekt auftrat: Normales "Warmlaufen", d. h. erst mal Lampe
an, Schlitten versucht in die Ausgangsposition zu fahren, kann sich
nicht bewegen, Schrittmotor brummt noch ein wenig, schaltet sich aus und
es wird über die LED noch ein Fehlercode angezeigt. Inzwischen schaltete
sich, wie üblich, die Lampe vom Scanner wieder aus.

Nach einiger Zeit habe ich nun endlich mal wieder Zeit mich mit dem
Scanner zu beschàftigen. Nach dem Einschalten brennt die Lampe, wie
immer, ansonsten passiert nix.

Der Schrittmotor wird von einem UL2003L angetrieben. Beim Einschalten
des Scanners veràndert sich die Spannung an den Ausgàngen mit dem
Multimeter sichtbar von 20 auf 18 V, dann wieder auf 20 V (Spannung aus
dem Netzteil, ansonsten werden noch 12 und 5 V auf der Platine
bereitgestellt). Geràusche vom Schrittmotor gibt's keine mehr. Die
Eingànge des UL2003L bleiben nach Einschalten bei 0,06 V, also Null. Ich
vermute mal keine Steuerung von der "Zentrale" mehr, anscheinend ein
Fehlerspeicher?


Hat einer eine Idee zur Reparatur?


Ciao, Andreas
 

Lesen sie die antworten

#1 Leo Baumann
04/11/2008 - 02:59 | Warnen spam
.. mein Vorschlag wàre folgender Versuch:

mechanisch in Mittelposition bringen und einen Hardware-Reset am
Mikrocontroller ausführen ..

sonst sieht's übel aus

mfG Leo

Ähnliche fragen