SCSI-Scanner

07/04/2013 - 17:48 von Julius Kavay | Report spam
Hallo,

habe ein Problem mit einem SCSI-Scanner... aber das Ganze von Anfang an.

meine Frau hat als Privat-PC ein Ubuntu 10.04.4, an dem ist ein
Scanner ueber SCSI angeschlossen (im PC ist ein Adaptec AIC-7850).

Alles funktionierte problemlos, aber jetzt hat sie einen zweiten
PC (*) bekommen. Um an die neuen PC Bildschirm, Strom, Netzwerk usw.
anschliessen zu koennen, musste ich den Scanner wegnehmen (Strom- und
SCSI-Kabel abgesteckt, mehr war's nicht).

Nachdem ich die beiden PCs (ueber ein KVM-Switch) an Monitor, Tastatur
und Maus wieder angesteckt habe und auch der Scanner an seinem alten
Platz stand, Strom und SCSI-Kabel angesteckt wurde, funktioniert wieder
alles, bis auf den Scanner, denn Ubuntu erkennt den Scanner nicht mehr.

Folgende Infos haette ich:

1)
helga@helga:~$ lspci | grep SCSI
06:00.0 SCSI storage controller: Adaptec AIC-7850 (rev 03)
helga@helga:~$

2)
helga@helga:~$ ls -la /proc/scsi
total 0
dr-xr-xr-x 4 root root 0 2013-04-06 01:30 .
dr-xr-xr-x 181 root root 0 2013-04-01 19:29 ..
dr-xr-xr-x 2 root root 0 2013-04-06 01:30 aic7xxx
-r--r--r-- 1 root root 0 2013-04-06 01:30 device_info
-r--r--r-- 1 root root 0 2013-04-06 01:30 scsi
dr-xr-xr-x 2 root root 0 2013-04-06 01:30 sg

3)
helga@helga:~$ ls -la /proc/scsi/aic7xxx
total 0
dr-xr-xr-x 2 root root 0 2013-04-07 11:36 .
dr-xr-xr-x 4 root root 0 2013-04-07 11:36 ..
-rw-r--r-- 1 root root 0 2013-04-07 11:36 6

4)
helga@helga:~$ cat /proc/scsi/scsi
Attached devices:
Host: scsi1 Channel: 00 Id: 00 Lun: 00
Vendor: ATA Model: WDC WD1003FBYX-0 Rev: 01.0
Type: Direct-Access ANSI SCSI revision: 05
Host: scsi3 Channel: 00 Id: 00 Lun: 00
Vendor: HL-DT-ST Model: DVDRAM GH24NS95 Rev: RN00
Type: CD-ROM ANSI SCSI revision: 05
Host: scsi4 Channel: 00 Id: 01 Lun: 00
Vendor: PHILIPS Model: SPD6005T Rev: P1.0
Type: CD-ROM ANSI SCSI revision: 05

5)
helga@helga:~$ cat /proc/scsi/aic7xxx/6
Adaptec AIC7xxx driver version: 7.0
Adaptec 2902/04/10/15/20C/30C SCSI adapter
aic7850: Single Channel A, SCSI Id=7, 3/253 SCBs
Allocated SCBs: 4, SG List Length: 128

No Serial EEPROM

Target 0 Negotiation Settings
User: 80.000MB/s transfers (80.000MHz, offset 127)
Target 1 Negotiation Settings
User: 80.000MB/s transfers (80.000MHz, offset 127)
Target 2 Negotiation Settings
User: 80.000MB/s transfers (80.000MHz, offset 127)
Target 3 Negotiation Settings
User: 80.000MB/s transfers (80.000MHz, offset 127)
Target 4 Negotiation Settings
User: 80.000MB/s transfers (80.000MHz, offset 127)
Target 5 Negotiation Settings
User: 80.000MB/s transfers (80.000MHz, offset 127)
Target 6 Negotiation Settings
User: 80.000MB/s transfers (80.000MHz, offset 127)
Target 7 Negotiation Settings
User: 80.000MB/s transfers (80.000MHz, offset 127)

6)
helga@helga:~$ sane-find-scanner

# sane-find-scanner will now attempt to detect your scanner. If the
# result is different from what you expected, first make sure your
# scanner is powered up and properly connected to your computer.

# No SCSI scanners found. If you expected something different, make
sure that
# you have loaded a kernel SCSI driver for your SCSI adapter.

# No USB scanners found. If you expected something different, make
sure that
# you have loaded a kernel driver for your USB host controller and
have setup
# the USB system correctly. See man sane-usb for details.

# Not checking for parallel port scanners.

# Most Scanners connected to the parallel port or other proprietary ports
# can't be detected by this program.

# You may want to run this program as root to find all devices. Once you
# found the scanner devices, be sure to adjust access permissions as
# necessary.



Koennte es sein, dass ich das SCSI-Kabel beleidigt (ist ein "wenig"
abgewinkelt) habe?

Wie gesagt, vor dem Abstecken des Scanners hat der problemlos
funktioniert. Ich weiss, never change a running team...

Ich habe keine Ahnung, wo das Problem liegt. Gut, ich
bin auch nicht der ultimative Linux Kenner...
Frage daher, sieht jemand etwas was ich nicht sehe?

Gruesse
Julius


(*) eigentlich sollte sie nur eine virtuelle Maschiene mit Win7
bekommen wo sie ueber unsere Reisen Fotoshows auf DVD macht,
aber eine "kranke Windows-Anwendung" wollte partout nicht in
einem virtuellen System installiert werden...
(my real mail address ends with a .net tld)
 

Lesen sie die antworten

#1 Johann Mayerwieser
07/04/2013 - 19:46 | Warnen spam
Am Sun, 07 Apr 2013 17:48:46 +0200 schrieb Julius Kavay:

Hallo,



(Scanner funktioniert nach Ab- und Anstecken nicht mehr)

Hallo,
ich bin auch kein Linux-Guru, ich würde als erstes die Steckverbindungen
des Scanners kontrollieren - das geht bis zu den einzelnen Kontakten -
sind Stifte verboten, gefederte Kontakte noch ausreichend federnd etc.

Hannes



Rechtschreibfehler unterliegen der Creative Commons Lizenz, sie dürfen
weiterverwendet und veràndert werden, bei Weiterverwendung muss der
Urheber genannt werden und sie dürfen jeweils nur unter dieser oder einer
vergleichbaren Lizenz weitergegeben werden.

Ähnliche fragen