seltsames Device

25/10/2013 - 17:31 von Magnus Warker | Report spam
Hallo,

ein Rechner hat nur eine Platte (/dev/sda).

Ab und zu stöpsele ich da eine externe Platte oder einen USB-Stick ein.
Dieses Geràt wird dann das Device (/dev/sdb1). Das ist momentan aber
nicht der Fall.

Dennoch liefert ls -la /dev/sd* folgendes Ergebnis:

brw-rwT 1 root disk 8, 0 Oct 23 17:49 /dev/sda
brw-rwT 1 root disk 8, 1 Sep 28 16:40 /dev/sda1
brw-rwT 1 root disk 8, 2 Sep 28 16:40 /dev/sda2
brw-rwT 1 root disk 8, 5 Sep 28 16:40 /dev/sda5
brw-rwT 1 root disk 8, 6 Sep 28 16:40 /dev/sda6
brw-rwT 1 root floppy 8, 17 Oct 3 17:58 /dev/sdb1

Auffàllt, dass es zu /dev/sdb1 kein /dev/sdb gibt!?

Wie auch immer, das Problem ist folgendes:

Wenn ich jetzt eine Platte anhànge, erscheint zusàtzlich /dev/sdb, aber
das /dev/sdb1 dürfte *irgendwie* noch das seltsame von vorhin sein, denn
ich kann darauf nicht zugreifen.

Es handelt sich zwar um ein mit cryptosetup verschlüsseltes Dateisystem
und es könnte theoretisch noch andere Gründe für den nicht
funktionierenden Zugriff geben, aber mich stört eigentlich schon, dass
ich bei ausgeschaltetem Geràt ein /dev/sdb1 ohne /dev/sdb habe.

Was kann das sein und wie kann man da aufràumen?

Danke
Magnus
 

Lesen sie die antworten

#1 Klaus von der Heyde
25/10/2013 - 18:01 | Warnen spam
Magnus Warker wrote:

Wenn ich jetzt eine Platte anhànge, erscheint zusàtzlich /dev/sdb,
aber das /dev/sdb1 dürfte *irgendwie* noch das seltsame von vorhin
sein, denn ich kann darauf nicht zugreifen.



Wie ist die Partitionierung?
Mit was wird zugegriffen und wie lautet die Fehlermeldung?
Könnte es sein, dass noch ein Prozess /dev/sdb1 benutzt?

aber mich stört eigentlich
schon, dass ich bei ausgeschaltetem Geràt ein /dev/sdb1 ohne
/dev/sdb habe.



Das war früher® gang und gàbe und sollte di Funktion nicht
beeinflussen, wenn keine Prozesse die Geràtedatei verwenden.

Klaus

Ähnliche fragen