Seltsames Problem mit FTP/TFTP/CIFS

17/02/2010 - 15:57 von Ansgar Strickerschmidt | Report spam
Hallo alle,

habe ein etwas merkwürdiges Problem:

Ich importiere von einem NAS (Qnap Turbo Station TS-239 Pro mit aktueller
Firmware vom 9.2.10) ein Verzeichnis auf einen kleinen extra-Linuxserver
(Ubuntu 9.10 Server), normalerweise per CIFS (Samba).
Die mount-Anweisung in der /etc/fstab sieht also so aus:

//192.168.0.x/Public /mnt/p cifs
rw,username=xxxxx,password=yyyyy,defaults,iocharset=iso8859-15

Der betr. User xxxxx existiert auf dem NAS und hat Vollzugriff auf dem
Share.

Auf der Linux-Kiste soll ein Unterverzeichnis "TFTP" des importierten
Shares nun per FTP (vsftpd) und TFTP (Standard-in.tftpd) wieder
ausgeliefert werden.
Dazu existieren zwei Symlinks: /srv/ftp und /srv/tftp, die beide
gleichermaßen auf /mnt/p/TFTP zeigen. So weit, so gut.

Nun kommt's:
Per (Anonymous-)FTP kann ich mit diesem Setup Dateien aus dem
eingebundenen FTP/TFTP-Verzeichnis herunterladen.
Per TFTP bekomme ich reproduzierbar einen "Error 2 - Access violation".
Die Rechte an den betr. Dateien und (Unter-)Verzeichnissen aus Sicht der
Linux-Maschine sind 755, Benutzer root, Gruppe root. Wie gesagt, anonymes
FTP liefert die Dateien aus...

Verwende ich zum Mounten stattdessen NFS:

192.168.0.x:/Public /mnt/p nfs rw 0 0

- mit sonst völlig unverànderten Einstellungen! - funktioniert auch TFTP!
Da brat mir einer 'nen Elch...

Ich möchte aber an sich, aus Gründen der Einheitlichkeit mit weiteren
eingebundenen Shares, lieber CIFS benutzen, wenn das geht. Außerdem wüsste
ich gerne mehr über die Hintergründe... wo ist denn da der Haken versteckt?
Ist das evtl. ein Bug von Ubuntus mitgebrachtem Samba 3.4.0-Client?

Ratlos

Ansgar

*** Musik! ***
 

Lesen sie die antworten

#1 Heiko Schlenker
17/02/2010 - 16:55 | Warnen spam
* Ansgar Strickerschmidt schrieb:

Ich möchte aber an sich, aus Gründen der Einheitlichkeit mit weiteren
eingebundenen Shares, lieber CIFS benutzen, wenn das geht. Außerdem wüsste
ich gerne mehr über die Hintergründe... wo ist denn da der Haken versteckt?
Ist das evtl. ein Bug von Ubuntus mitgebrachtem Samba 3.4.0-Client?



Schnellschüsse (Samba-Server-Konfiguration):
- follow symlinks
- wide links

Gruß, Heiko

Ähnliche fragen