Seltsames Verhalten bei Abfragen

23/04/2008 - 15:10 von Thomas_INEOS | Report spam
Hallo,
Derzeit entwickle ich eine Anwendung im Bereich Kundenverwaltung. Hierbei
werden nachdem der Kunde ausgewàhlt wurde, verschiedene Abfragen gestartet,
z.b. Umsatz oder vergleichbar. Die Verküpfung làuft meist über die
Kundennummer.
Nach Kundenauswahl stehen also automatisch verschiedene Auswertungen bereit.
Klappt alles wunderbar, also sind offenbar keine schweren Fehler im Code.
Nur bei einem Rechner erscheiint für jede Abfrage ein Access-Dialogfeld, das
nach dem benutzten Filterwert (Kundennr) fragt. Gebe ich die Nummer ein,
klappt der Rest für die jeweilige Abfrage. Das wiederholt sich dann für jede
folgende Abfrage.
Ich vermute, dass irgend eine Access Einstellung verhindert, dass dieser
Rechnung den Verweis ignoriert, wàhrend andere Rechner ihn verarbeiten.
Die beschreibung des Fehlers ist nicht einfach, daher bitte ich um
Entschuldigung. Das unterschjiedliche Verhalten der Rechner irritiert mich.
Alle Rechner sind in einem Firmennetzwerk und erhalten regelàßig alle
notwendigen Updates und haben alle die gleiche Access-Version installiert.
 

Lesen sie die antworten

#1 Karl Donaubauer
23/04/2008 - 15:58 | Warnen spam
Thomas_INEOS wrote:
Derzeit entwickle ich eine Anwendung im Bereich Kundenverwaltung.
Hierbei werden nachdem der Kunde ausgewàhlt wurde, verschiedene
Abfragen gestartet, z.b. Umsatz oder vergleichbar. Die Verküpfung
làuft meist über die Kundennummer.
Nach Kundenauswahl stehen also automatisch verschiedene Auswertungen
bereit. Klappt alles wunderbar, also sind offenbar keine schweren
Fehler im Code. Nur bei einem Rechner erscheiint für jede Abfrage ein
Access-Dialogfeld, das nach dem benutzten Filterwert (Kundennr)
fragt. Gebe ich die Nummer ein, klappt der Rest für die jeweilige
Abfrage. Das wiederholt sich dann für jede folgende Abfrage.
Ich vermute, dass irgend eine Access Einstellung verhindert, dass
dieser Rechnung den Verweis ignoriert, wàhrend andere Rechner ihn
verarbeiten.
Die beschreibung des Fehlers ist nicht einfach, daher bitte ich um
Entschuldigung. Das unterschjiedliche Verhalten der Rechner irritiert
mich. Alle Rechner sind in einem Firmennetzwerk und erhalten
regelàßig alle notwendigen Updates und haben alle die gleiche
Access-Version installiert.



Und die willst du nicht verraten?

Mir ist auch nicht ganz klar, wie du diese "Verknüpfung" über die
Kundennummer herstellst und wie die Abfragen "gestartet" werden.
Sprichst du von einem Formularbezug in den Kriterien der Abfragen?
Bastelst du SQL-Strings etc. per Code?

Diese Dinge solltest du noch etwas beschreiben und ggf. relevante
Codebeispiele oder SQL-Texte einer Abfrage hier posten.

cu
Karl
********* Ich beantworte keine Access-Fragen per Email. *********
Access-FAQ: http://www.donkarl.com
+ Entwickler-Konferenzen für Access (AEK) und SQL Server (SEK)

Ähnliche fragen