Sendkeys wird nur im Code ausgeführt, nicht in der Anwendung

18/12/2009 - 09:40 von Christoph | Report spam
Hallo Zusammen,
ich würde mich sehr über Eure Hilfe zu folgendem Problem freuen:
Nach der Umstellung auf Win7 (Access 2003) wird eine Sendkeys Anweisung auf
einem NetzPc richtig ausgegführt, auf allen anderen wird diese Anweisung
nicht im Formular, sondern direkt im Code ausgeführt. Die Prodzedur ist auf
allen PC's gleichlautend. Es muß an irgendeiner Rahmeneinstellung im Access
liegen.
Weiß jemand von Euch, an welcher?
Herzlichen Dank im Voraus für die Hilfe!
Christoph
 

Lesen sie die antworten

#1 Karl Donaubauer
18/12/2009 - 10:08 | Warnen spam
Christoph wrote:
ich würde mich sehr über Eure Hilfe zu folgendem Problem freuen:
Nach der Umstellung auf Win7 (Access 2003) wird eine Sendkeys
Anweisung auf einem NetzPc richtig ausgegführt, auf allen anderen
wird diese Anweisung nicht im Formular, sondern direkt im Code
ausgeführt. Die Prodzedur ist auf allen PC's gleichlautend. Es muß
an irgendeiner Rahmeneinstellung im Access liegen.
Weiß jemand von Euch, an welcher?



Was genau meinst du mit "direkt im Code ausgeführt"?
Welches SP von Office 2003 ist installiert?
Ist der SP-Stand auf der funktionierenden Maschine unterschiedlich?

Sendkeys macht oft und gerne Probleme, nicht erst, seit sein
Funktionieren auch noch von Windows- oder SP-Versionen
abhàngt. z.B. sollte das SP3 für O03installiert sein samt zugehörigem
Hotfix, s. http://support.microsoft.com/kb/938792/en-us
und www.donkarl.com/?FAQ9.1.

Du solltest daher versuchen, Sendkeys generell zu vermeiden.
Wenn du verràtst, wie und wofür du es genau einsetzt, làsst sich
evtl. eine stabilere Lösung finden.

Servus
Karl
********* Ich beantworte keine Access-Fragen per Email. *********
Access-FAQ: http://www.donkarl.com

Ähnliche fragen