Seriendruck und leeres Datumsfeld

01/09/2009 - 19:41 von Jörg Burzeja | Report spam
Hallo zusammen,

in Excel gibt es eine Formel für ein Datum:
=WENN(A3="";"";A3+7)

Es werden also 7 Tage hinzuaddiert.

Das Feld ist in Word eingebunden mit:

{MERGEFIELD "Datum_2" \@ "dd.MM.yyyy"}

Nun funktioniert das alles, aber wenn A3 leer ist, gibt Excel mit der
Wenn-Formel (wie es soll) auch leer (scheinbar aber nicht IsNull)
zurück, und liefert nach word das Systemdatum.

Kann man das irgendwie einstellen, dass ein leeres Datumsfeld in Excel
in einem Seriendruckfeld in Word nicht befüllt wird?

Ein Ersatzzeichen wàre nicht so gut, weil spàter ein Datenimport
vorgesehen ist, und das auf Fehler laufen würde.


Viele Grüsse

Jörg
 

Lesen sie die antworten

#1 Jörg Burzeja
01/09/2009 - 21:39 | Warnen spam
Jörg Burzeja schrieb:

in Excel gibt es eine Formel für ein Datum:
=WENN(A3="";"";A3+7)

Es werden also 7 Tage hinzuaddiert.

Das Feld ist in Word eingebunden mit:

{MERGEFIELD "Datum_2" \@ "dd.MM.yyyy"}

Nun funktioniert das alles, aber wenn A3 leer ist, gibt Excel mit der
Wenn-Formel (wie es soll) auch leer (scheinbar aber nicht IsNull)
zurück, und liefert nach word das Systemdatum.

Kann man das irgendwie einstellen, dass ein leeres Datumsfeld in Excel
in einem Seriendruckfeld in Word nicht befüllt wird?

Ein Ersatzzeichen wàre nicht so gut, weil spàter ein Datenimport
vorgesehen ist, und das auf Fehler laufen würde.



Vergessen:
Das ganze unter WW 2003


Unter WW 2007 mit neuen Format (...x.*) kommt es aber noch besser:

{MERGEFIELD "Datum_2" \@ "dd.MM.yyyy"}
Der Schalter vertauscht Tag und Monat; aber nicht generell, sondern nur
wenn dies auch Sinn ergibt.

Ohne Schalter ist es okay.

Also mit Schalter wird:
vertauscht 05.09.2009 in 09.05.2009
vertauscht nicht: 30.08.2009 in 08.30.2009 (immerhin das merkt Word)

Nun das ganze ohne Schalter unter WW 2007 ohne neues Format (...x.*)
gespeichert (also kompatibel zu WW 2003) -

4/12/2009

Das bedeutet, auch WW 2007 benötigt die Schalter.

Das sieht mir nach einem üblen Bug aus, denn WW 2003 User werden wohl
hàufig den Schalter verwenden.

Viele Grüsse

Jörg

Ähnliche fragen