Server 2008 IPv6

04/08/2008 - 14:10 von Sabine K | Report spam
Hallöchen Zusammen,

jetzt habe ich auch mal eine doch recht trickreiche Frage.
Ich konfiguriere derzeit einen neuen Microsoft 2008 Server in einer VMWare
Umgebung.
Dort habe ich ein Problem mit dem DHCP Server!
Die Einrichtung des IPv4 funktioniert einwandfrei, der Client erhàlt alles
notwendige (IP-Adresse, Namensauflösung)
Nun habeich den IPv6 Bereich im DHCP konfiguriert (Adressbereich fec0). Wenn
ich nun IPv4 ausschalte, bekommt der Client keine Adresse vom IPv6 Bereich
zugewiesen. Statt dessen erhàlt er eine fe80 (alte APIPA-Adresse). Die
VMWare Umgebung ist auch so eingerichtet, daß sie mit IPv6 umgehen kann.
Was làuft da schief und wer hat Erfahrung mit IPv6 und Windows 2008?

Gruß
Bine
 

Lesen sie die antworten

#1 Sabine K.
09/08/2008 - 12:07 | Warnen spam
Hallöle Zusammen,

da ich wohl mit IPv6 ein ziemlich heißes Eisen angefaßt habe und mir kaum
bzw. niemand eine Antwort geben konnte hab ich mit Hilfe eines netten
Menschen getüftelt. Dabei kam dann folgendes funktionierendes heraus:

Ein Client kann eine IPv6 Adresse nur von einem routingfàhigen Geràt
bekommen. Demnach ist es nicht so einfach wie gewohnt IPv6 Adressen vom DHCP
zu bekommen. Wir bzw. der nette Mensch hat dann folgendes ausgetüftelt:

- DHCP wie gewohnt installieren
- IPv6 Bereich bestimmen
- ROUTER KONFIGURIEREN
* Forwarding einschalten
netsh interface ipv6 set interface "Schnittstellenname"
forwarding=enabled advertise=enabled
* Stateful Address einschalten
netsh interface ipv6 set interface "Schnittstellenname"
manageaddress=enabled
* Stateful Options einschalten
netsh interface ipv6 set interface "Schnittstellenname"
othersateful=enabled

!! Eventuell beide Routerschnittstellen wie oben konfigurieren!!

Es funktioniert!! Na was sagt Ihr dazu?

Gruß
Bine


"Sabine K" schrieb im Newsbeitrag
news:
Hallöchen Zusammen,

jetzt habe ich auch mal eine doch recht trickreiche Frage.
Ich konfiguriere derzeit einen neuen Microsoft 2008 Server in einer VMWare
Umgebung.
Dort habe ich ein Problem mit dem DHCP Server!
Die Einrichtung des IPv4 funktioniert einwandfrei, der Client erhàlt alles
notwendige (IP-Adresse, Namensauflösung)
Nun habeich den IPv6 Bereich im DHCP konfiguriert (Adressbereich fec0).
Wenn ich nun IPv4 ausschalte, bekommt der Client keine Adresse vom IPv6
Bereich zugewiesen. Statt dessen erhàlt er eine fe80 (alte APIPA-Adresse).
Die VMWare Umgebung ist auch so eingerichtet, daß sie mit IPv6 umgehen
kann.
Was làuft da schief und wer hat Erfahrung mit IPv6 und Windows 2008?

Gruß
Bine

Ähnliche fragen