Setup mit VS2008 und .NET 2.0 erstellen

29/09/2008 - 23:41 von M.Erlinger | Report spam
Hallo

ich habe für eine Applikation im Framework .NET 2.0 ein Setup
erstellt, in dem ich in den "Prerequisites" nur das Framework 2.0
ausgewàlht habe.

Wenn ich das Setup jetzt auf einer XP-Maschine ausführe, wird
ordnungsgemàß das .NET 2.0 installiert, aber nachher möchte das Setup
immer das Framework 3.5 installieren - und wenn ich die MessageBox-
Abfrage mit "no" beantworte, endet die Setup-Routine.
Der genau Wortlaut der Meldung ist:
"This setup requires the .NET Framework 3.5. Please install the .NET
Framework and runt this setup again. The .NET.. Would you like to
do this now?"

Aus welchem Grund will d. Setup hier ein Framework 3.5??

Entwickelt habe ich das ganze auf einem Vista-Rechner mit VS 2008
Prof.

Kann mir dazu bitte jemand weiterhelfen!!!
Danke und Grüße
Michael
 

Lesen sie die antworten

#1 Thomas Griepentrog
30/09/2008 - 09:30 | Warnen spam
Hallo Michael,

du mußt bei den "gefundene Abhàngigkeiten" mal auf das "Microsoft .NET
Framework" klicken.

Dort stellst du dann bei den Properties ein:
Version: 2.0.50727

Da wird dann "nur" das .NET 2.0 installiert.
Irgendwie scheint da ein größerer Bug im VS zu sein, da du nicht der erste
bist mit diesem Problem.

Thomas

Ähnliche fragen