Simples Formelproblem? A1 Zellbezug

05/10/2009 - 18:07 von ChristianJohn81 | Report spam
Hallo Community,

hier die Formel an er irgendwas falsch sein muss:

=WENN(SVERWEIS($A4;"'"&$A$2&"'!$A$2:$AA$874";2;FALSCH)<>SVERWEIS
($A4;"'"&$B$2&"'!$A$2:$AA$874";2;FALSCH);SVERWEIS($A4;"'"&$B$2&"'!$A
$2:$AA$874";2;FALSCH);"")

In A2 und B2 steht der Name des jeweiligen Tabellenblattes das
verglichen werden soll.
Suchkriterium ist was in Spalte A steht. Danach soll er auf jedem
dieser beiden Blàtter suchen und vergleichen. Bei Ungleichheit eben
das eine wiedergeben.

Ich denke das Problem liegt einfach daran, dass ich das mit dem
Blattnamen in der Formel (die in A2 und B2 stehen) nicht richtig
gemacht habe...?!

Vielen Dank!

Grüße
Christian John
 

Lesen sie die antworten

#1 Dietmar Vollmeier
05/10/2009 - 18:37 | Warnen spam
Servus Christian!

** schrieb...
Ich denke das Problem liegt einfach daran, dass ich das mit dem
Blattnamen in der Formel (die in A2 und B2 stehen) nicht richtig
gemacht habe...?!



Namen, die du für Verweise benötigst, stellst du mit INDIREKT()
zusammen.

Zum Beispiel
=SVERWEIS(A2;INDIREKT(B2&"!"&C2);1)

Beachte aber, daß der Verweis auf _andere_ Arbeitsmappen mit INDIREKT()
nur dann funktioniert, wenn diese geöffnet sind!
und tschüss | Ein Schiff, das im Hafen liegt, ist sicher.
Didi | Aber dafür werden Schiffe nicht gebaut.

Ähnliche fragen