SMB/CIFS: cifsd killed bei falschen passwort

04/06/2009 - 16:58 von Thomas Anglmaier | Report spam
Hallo Leute,

früher gabs hier mal ein paar Samba Spezialisten darum versuch ich mein
Glück mal hier.

ich hab hier ein Problem beim mounten von Samba-shares mittels cifs.
Jedesmal wenn ein User eine falschs Passwort angibt wird der [cifsd]
kernel thread gekillt und dadurch gehen alle bereits mounted shares
verloren.

Die cifs-documentation sagt dazu etwas wie "Es wird für jeden Server
(ip) ein cifsd thread erstellt."

Auf folgenden Systemen(Server+Client) konnte ich das Verhalten
nachstellen: RHEL 5.3, Debian Lenny, SLES 10

Der hier angeführte Test wurde auf folgenden Versionen durchgeführt:
Red Hat Enterprise Linux Server release 5.3 (Tikanga)
Kernel: 2.6.18-128.1.10.el5
Samba Version: 3.0.33-3.7.el5
cifs module version: 1.54RH


so sieht das ganze in der praxis aus:
http://pastebin.com/f1df8652

#dmesg ausgabe bei zweiten mount versuch mit falschem passwort
http://pastebin.com/f797efeab

#kein cifsd mehr
[root@tofo2 ~]# ps aux | grep cifsd | grep -v grep
root 2643 0.0 0.0 0 0 ? S< 11:35 0:00
[cifsdnotifyd]


Die Zeile die mir besonders Sorgen macht:
fs/cifs/connect.c: cifsd thread killed

Das sieht für mich so aus als wàre das ganz normales Verhalten. Nur
leider ist das ein echter Showstopper.

weiters...
fs/cifs/connect.c: Existing tcp session with server found
fs/cifs/connect.c: Existing smb sess not found

Für mein naives Verstàndnis sollte da doch irgendwas wie "Existing smb
sess found" statt "Existing smb sess *not* found" stehen.

Kennt das Problem vielleicht jemand?


LG
Thomas
 

Lesen sie die antworten

#1 K(o)arl Szalcsak
06/06/2009 - 10:05 | Warnen spam
Thomas Anglmaier wrote:

ich hab hier ein Problem beim mounten von Samba-shares mittels cifs.


...
Kennt das Problem vielleicht jemand?




Seawas Thomas!

Ich hatte letztens in der Firma ein àhnliches cifs-Mountproblem, das in
"mount error 13 = Permission denied" -Generve endete.
In /etc/fstab waren Username und password bei den options mit spezifiziert.
Das volume wollte sich dann von root partout nicht mounten lassen.
Ich weiß, soll man eh nicht tun, geheimes Zeugs in /etc/fstab schreiben.

Der Spuk verschwand, nachdem mir Kollege Michl zum Anlegen des
Files /root/.credentials geraten hatte. Seltsam, unerklàrlich, wohl noch
net ganz ausgereift, die Sache...

Nàhere Details kann ich dir ab Mo sagen, hab jetzt keinen Zugriff auf den
Firmen-PC.

griaß,

koarrl

Ähnliche fragen