Sortieren von Namen in Spalten mit Formeln

18/02/2008 - 23:53 von Ralf Schönberger | Report spam
Hallo zusammen,

ich habe eine Tabelle in der ich nichts veràndern darf. Dort stehen
Namen in Spalte B und Anrede in C mit Leerzeilen, die ich ohne
Leerzeilen aufsteigend sortieren möchte. Zu jedem Namen gibt es eine
fortlaufende Nummer in A mit:

=WENN(B:B<>"";ZÄHLENWENN(B$2:B2;">""");"")

Die Namen mit Anrede über INDEX-VERGLEICH auf ein neues Blatt ohne
Leerzeilen einzufügen ist kein Problem. Aber wie kann ich die Namen
(nur Nachnamen) aufsteigend sortieren. Mit Filtern ist das nicht zu
machen wegen der Formeln.

Kann mir jemand helfen? Habe MS Excel 2003.

Danke und Grüsse
Ralf Schönberger
 

Lesen sie die antworten

#1 Klaus \Perry\ Pago
19/02/2008 - 01:10 | Warnen spam
Hallo Ralf,

"Ralf Schönberger" schrieb im Newsbeitrag
news:
Hallo zusammen,

ich habe eine Tabelle in der ich nichts veràndern darf. Dort stehen
Namen in Spalte B und Anrede in C mit Leerzeilen, die ich ohne
Leerzeilen aufsteigend sortieren möchte. Zu jedem Namen gibt es eine
fortlaufende Nummer in A mit:

=WENN(B:B<>"";ZÄHLENWENN(B$2:B2;">""");"")

Die Namen mit Anrede über INDEX-VERGLEICH auf ein neues Blatt ohne
Leerzeilen einzufügen ist kein Problem. Aber wie kann ich die Namen
(nur Nachnamen) aufsteigend sortieren. Mit Filtern ist das nicht zu
machen wegen der Formeln.

Kann mir jemand helfen? Habe MS Excel 2003.



es gibt die Möglichkeit, mit sog. Matrixformeln die gewünschte Sortierung
vorzunehmen. Allerdings wird die Lösung nach einigen hundert Zeilen extrem
langsam. Um wie viele Zeilen handelt es sich bei deiner Datei und in welchem
Bereich (B2:B500 ?) befindet sie sich? Soll die berechnete fortlaufende
Nummer mit sortiert werden? Vermutlich kann man sie mittels SVERWEIS
einfacher ermitteln.

Gruß
Klaus

Ähnliche fragen