Forums Neueste Beiträge
 

Sortieren von Tabellen

23/10/2007 - 22:31 von Harald Lecher | Report spam
Hallo
Ich habe ein kleines Problem in einer Excel-Tabell beim sortieren.
Vielleicht kann mir einer Helfen.
Es handelt sich um eine Tabelle zur Mannschaftsauswertung beim Kegeln
Es spielen mehrere Mannschaften.
Von jeder Mannschaft (die ein eigenes Tabellenblatt hat) bekomme ich ein
Ergbnis wie viele Punkte sie gemacht haben.
In der Tabelle in der ich die Auswertung bearbeiten möchte sthet
z.B.folgende Formel.
=WENN($B6="";"";SUMME('Spielplan Team 3'!$H$48))
Damit wird mir der Wert den die Mannschaft erreicht hat angezeigt z.B. 945
In der nàchsten Zeile steht.
=WENN($B7="";"";SUMME('Spielplan Team 4'!$H$48))
In der Zelle wird dann z.B. 981 angezeigt.
So nun mein Problem.
Wenn ich die Liste nun nach den Summen sortieren will, damit ich sehe welche
Mannschaft die beste war und in meiner Liste ganz oben steht, sortiert mir
Excel nicht nach den Werten sondern nach der Formel.
Also ...$B6... steht ganz oben dann ...$B7usw.
Was muss ich machen damit Excel mir nach der Zahl sortiert.

Vielen Dank
Harald Lecher
 

Lesen sie die antworten

#1 Alexander Wolff
23/10/2007 - 23:44 | Warnen spam
=WENN($B$6="";"";'Spielplan Team 3'!$H$48) reicht übrigens aus, wenn Du mit
SUMME nicht einen möglichen Textfehler abfangen möchtest.

$H$48 darf auch als H48 geschrieben sein, wàhrend $B6 hier als $B$6
geschrieben sein muss. Formeln, die aus dem Sortierbereich herausverweisen,
sollte man diesbezüglich testen. Relative Bezüge tendieren dazu, relativ
beim Sort mitzugehen und damit die Verweise zu brechen/sinnzuentstellen.
Moin+Gruss Alexander - MVP für MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen