Sortierung

08/09/2009 - 18:10 von friedhelm beckadolf | Report spam
Hallo und guten Tag werte newsgroupler,

ich arbeite mir Office 2007 und habe in Excel folgendes Problem leider
bisher nicht lösen können:

In Spalte "D" stehen Werte, die folgenden Aufbau haben:
SD1014/2223/PI1
SD1014/1809ST1
SD1014/1766/CO1
SD1014/2061KUE1
SD1014/2167/RUE1
SD1014/1899MU1
SD1014/1958/CO1

Die Angaben in dieser Spalte muss ich nach den letzten 3 bzw. 4 Zeichen
sortieren (vier Zeichen immer dann, wenn der zweite Buchstabe eigentlich ein
"Ü" ist, aber als "UE" dargestellt wird).
Darüber hinaus ist da Zeichen vor dem Sortierkriterium nicht immer ein "/",
sondern kann auch eine Zahl sein. Somit fàllt eine Eingrenzung hierüber weg.

Wie kann ich diese für mich variable Auswertung erreichen ?

Werde jeden Tipp dankbar testen und anschließend selbstverstàndlich berichten.

Vielen Dank im Voraus
Friedhelm
 

Lesen sie die antworten

#1 Claus Busch
08/09/2009 - 18:33 | Warnen spam
Hallo Friedhelm,

"friedhelm beckadolf" wrote:

In Spalte "D" stehen Werte, die folgenden Aufbau haben:
SD1014/2223/PI1
SD1014/1809ST1
SD1014/1766/CO1
SD1014/2061KUE1
SD1014/2167/RUE1
SD1014/1899MU1
SD1014/1958/CO1

Die Angaben in dieser Spalte muss ich nach den letzten 3 bzw. 4 Zeichen
sortieren (vier Zeichen immer dann, wenn der zweite Buchstabe eigentlich ein
"Ü" ist, aber als "UE" dargestellt wird).
Darüber hinaus ist da Zeichen vor dem Sortierkriterium nicht immer ein "/",
sondern kann auch eine Zahl sein. Somit fàllt eine Eingrenzung hierüber weg.



deine Daten beginnen in D2. Mach dir eine Hilfsspalte mit folgender Formel
und sortiere dann danach:
=WENN(CODE(TEIL(D2;LÄNGE(D2)-3;1))<W;RECHTS(D2;3);RECHTS(D2;4))


Mit freundlichen Grüssen
Claus Busch
@Web-Interface

Windows XP SP2; Vista Ultimate
Office 2000 SP3; Office2007 Ultimate

Ähnliche fragen