soundkarte unter ubuntu mit alsa

17/09/2007 - 22:44 von emilio sanchez | Report spam
... hallo zusammen,

leider tuts auf meinem medion-laptop der sound nicht. nach der
installation von ubuntu feisty wird das modul snd-hda-intel geladen und
eine karte wird erkannt. das làßt sich per cat /proc/asound/cards
nachvollziehen. die karte gibt aber keinen mucks von sich. weder über
die lautsprecher noch über den kopfhörerausgang. dem modul kann man
parameter mitgeben, sodass für den betrieb der karte ein anderes model
zum einsatz kommt. keines davon hat irgendeine verànderung gebracht.
ebenso wenig erfolg brachte die neueste version von alsa (1.0.14)

auf der seite des alsa-projekts hab ich gelesen, dass die karten von
nvidia über das modul intel8x0 laufen sollten. also hab ich (nur) das
kompiliert (per ./configure --with-cards=intel8x0) und es geladen. dabei
wird keine karte erkannt. in meiner verzweiflung habe ich mir den
sourcecode von alsa-driver-1.0.14/sound/pci/intel8x0.c angeschaut. dort
finde ich eine struct, in der (nach meiner einschàtzung) die
hardware-kennungen der unterstützten devices aufgezàhlt werden. die
kennung meiner karte (10de:026c) war nicht dabei. ich habe also eine
entsprechende zeile hinzugefügt und die entsprechenden zeilen in den
intel-hda sourcen auskommentiert. nach kompilieren von alsa-driver, -lib
und -utils, wird aber nach wie vor keine soundkarte erkannt.

hat jemand noch ideen?

viel dank schonmal
emilio
 

Lesen sie die antworten

#1 Clemens Ladisch
18/09/2007 - 12:42 | Warnen spam
emilio sanchez schrieb:
auf der seite des alsa-projekts hab ich gelesen, dass die karten von
nvidia über das modul intel8x0 laufen sollten.



Das gilt nur für den AC'97-Controller. Der HDA-Controller làuft mit
snd-hda-intel.

leider tuts auf meinem medion-laptop der sound nicht. nach der
installation von ubuntu feisty wird das modul snd-hda-intel geladen und
eine karte wird erkannt. das làßt sich per cat /proc/asound/cards
nachvollziehen. die karte gibt aber keinen mucks von sich. weder über
die lautsprecher noch über den kopfhörerausgang. dem modul kann man
parameter mitgeben, sodass für den betrieb der karte ein anderes model
zum einsatz kommt. keines davon hat irgendeine verànderung gebracht.
ebenso wenig erfolg brachte die neueste version von alsa (1.0.14)



Probier mal die neueste Version von ALSA (1.0.15rc2).


Gruß
Clemens

Ähnliche fragen