Spaltensumme - Zirkelbezug

13/09/2011 - 13:10 von Rudolf Witt | Report spam
Hallo Newsgroup,

ich stehe vor folgendem Problem:

meine Tabelle bezieht ihre Daten aus einer externen Datenbank. Ich weiß also
nicht, wie viele Zeilen (Datensàtze) sie nach einer jeweiligen
Aktualisierung enthalten wird.

In Spalte B stehen numerische Werte, über die ich eine Summe bilden möchte
[also im Prinzip SUMME(B:B)]. Allerdings soll die Zelle mit dieser Summe
nicht irgendwo, sondern genau in Zelle B1 dargestellt werden, damit ich sie
beim Scrollen immer schön im Blick behalten kann ("Fenster fixieren").
Natürlich funktioniert die Summenformel dann nicht mehr ohne weiteres, denn
es entsteht ein Zirkelbezug.

Meine Lösung ist bisher eine Formel wie SUMME(B2:B99999), wobei 99999 einen
fiktiven Wert darstellt, der größer ist, als die maximal anzunehmende Anzahl
von Datensàtzen. Das funktioniert, ist aber nicht sehr elegant, weil
Ressourcen verschwendet werden, was man ab einer bestimmten Tabellengröße
oder -Komplexitàt deutlich spürt.

Gibt es eine bessere Lösung?

Danke für Eure Vorschlàge.

Gruß Rudi
 

Lesen sie die antworten

#1 Claus Busch
13/09/2011 - 13:31 | Warnen spam
Hallo Rudolf,

Am Tue, 13 Sep 2011 13:10:04 +0200 schrieb Rudolf Witt:

Meine Lösung ist bisher eine Formel wie SUMME(B2:B99999), wobei 99999 einen
fiktiven Wert darstellt, der größer ist, als die maximal anzunehmende Anzahl
von Datensàtzen. Das funktioniert, ist aber nicht sehr elegant, weil
Ressourcen verschwendet werden, was man ab einer bestimmten Tabellengröße
oder -Komplexitàt deutlich spürt.



wegen Zirkelbezug musst du leider in B2 mit deiner Summe beginnen.
Du könntest die exakte Größe des Bereichs angeben, indem du in B1
eingibst:
=SUMME( und dann in B2 klickst und mit STRG+Shift + Pfeil nach unten
den genauen Bereich angibst. Allerdings müsstest du dies bei jeder
Aktualisierung machen.
Deswegen bleibt dir nur, den wahrscheinlich größten Bereich in der
Summenformel anzugeben.


Mit freundlichen Grüßen
Claus Busch
Win XP Prof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2

Ähnliche fragen