Spamassassin l

27/09/2008 - 16:06 von Michael Wulz | Report spam
Hallo Community,

Ich hab folgendes Problem, vielleicht könnt Ihr mir weiterhelfen.

Ich verwende Spamassassin (3.2.5 auf Perl Version 5.10.0) auf einem
Debian Linux mit 2.6.18-6-686 Kernel. MTA ist exim4 (4.63-17) und amavisd-
new (1:2.4.2-6.1).

Zum automatischen Update meiner Spamassassin Regeln verwende ich das
rules-du-jour Update Script, welches tàglich die Regeln aktualisiert.

Ich habe seit kurzer Zeit das Problem, dass der spamd-Prozess oft auf 100%
CPU Load hàngt. Ein Neustart des spamassassin sieht dann folgendermaßen
aus:

# /etc/init.d/spamassassin restart
Restarting SpamAssassin Mail Filter Daemon: No /usr/bin/perl found
running; none killed.
[441] warn: server socket setup failed, retry 1: spamd: could not create
INET socket on 127.0.0.1:783: Address already in use
[441] warn: server socket setup failed, retry 2: spamd: could not create
INET socket on 127.0.0.1:783: Address already in use
[441] error: spamd: could not create INET socket on 127.0.0.1:783:
Address already in use
spamd: could not create INET socket on 127.0.0.1:783: Address already in
use

Ich muss diesen dann killen und wieder starten.

Ich habe in die /var/log/mail.err geshen, da steht nur der obenstehende
Output. In mail.info und mail.warn hab ich auch nichts besseres gefunden.

Kann es eventuell sein, dass spamassassin einfach so lange zum starten
braucht?

gruss
danke im Voraus an alle!

Michael
 

Lesen sie die antworten

#1 Andreas Leitgeb
28/09/2008 - 01:13 | Warnen spam
Michael Wulz wrote:
Ich verwende Spamassassin (3.2.5 auf Perl Version 5.10.0) auf einem
Debian Linux mit 2.6.18-6-686 Kernel.
# /etc/init.d/spamassassin restart
Restarting SpamAssassin Mail Filter Daemon: No /usr/bin/perl found
running; none killed.
Ich muss diesen dann killen und wieder starten.



Scheinbar sucht das "stop" (per restart) von /etc/init.d/spamassassin
nach einem /usr/bin/perl, was ich mal fuer eher unsicher halte.
(weils ja mehrere prozesse mit perl geben koennte)

Bevor du das naechste mal den prozess manuell killst, schau mal
wie er wirklich heisst, und wie /etc/init.d/spamassassin ihn
wirklich sucht.

Das war mal nur ein schuss ins blaue - warum der spamd auf 100%
rennt, dazu fallt mir nichts ein, ausser vielleicht mal einen
strace dranzuhaengen...

Ähnliche fragen