Speicher wird unterschiedlich erkannt. Warum?

17/06/2014 - 12:23 von Axel Pötzinger | Report spam
Hallo NG,

hab mir einen gebrauchten Rechner angeschafft, und der làuft auch soweit ok.
Nur einen Effekt habe ich, dass der den eingebauten Speicher je nach
Situation in unterschiedlicher Größe erkennt.
Das Board ist ein MSI K9VGM-V. Das hat 2 Speicher-Steckplàtze für DDR-2
Riegel.
Da waren 2 Riegel drin, einer mit 1GB und einer mit 512 MB.
Wenn ich den 1GB Riegel nur drin hab, dann kann es sein, dass das BIOS
diesen auch so erkennt (ganz selten). In der Regel erkennt es ihn als
768 MB. Steck ich den 512 MB dazu, dann erkennt das BIOS insgesamt 1GB,
als wàren da 2x 512 MB drin.
Nachdem ich in dieser Materie nicht drin bin, bin ich für Tips dankbar,
WO ansetzen!
Danke.

Servus
Axel
 

Lesen sie die antworten

#1 Marcel Müller
17/06/2014 - 14:46 | Warnen spam
Hallo,

Am 17.06.2014 12:23, schrieb Axel Pötzinger:
Nur einen Effekt habe ich, dass der den eingebauten Speicher je nach
Situation in unterschiedlicher Größe erkennt.
Das Board ist ein MSI K9VGM-V. Das hat 2 Speicher-Steckplàtze für DDR-2
Riegel.
Da waren 2 Riegel drin, einer mit 1GB und einer mit 512 MB.
Wenn ich den 1GB Riegel nur drin hab, dann kann es sein, dass das BIOS
diesen auch so erkennt (ganz selten). In der Regel erkennt es ihn als
768 MB.



??? - Wie soll den das gehen. Es gab doch noch gar keine 768 MB Riegel,
oder? Jedenfalls nicht für Consumer-Ware.

Steck ich den 512 MB dazu, dann erkennt das BIOS insgesamt 1GB,
als wàren da 2x 512 MB drin.
Nachdem ich in dieser Materie nicht drin bin, bin ich für Tips dankbar,
WO ansetzen!



Mal so ins Blaue: BIOS-Bug oder defekter Speicher.

Viele BIOSe probieren einfach aus, wie groß eine Speichermodul ist,
indem sie verschiedene Muster hineinschreiben und dann unter anderen
Adressen wieder lesen. Wenn das Muster da auftaucht, kann der Speicher
mit dem betreffenden Adressbit nichts anfangen. Eine wackelige
Adressleitung bei einem RAM oder eine zu langsame Reaktion auf die
Adressànderung hat u.U. dieselbe Wirkung.
Die 768 MB könnten ferner dadurch zustande kommen, dass das Modul aus
zwei Bànken besteht, von denen einen den Test manchmal besteht, wenn der
Bus nicht zu sehr belastet ist.
Wie gesagt, es ist eine Theorie.

Ich würde mal Marken-RAM reinstecken, was zumindest mal von der
Speicherorganisation her zum Mainboard passt. Wenn der Fehler dann immer
noch auftritt, hat wohl eher Mainboard oder BIOS einen Knacks. Eine halb
durchtrennte Leiterbahn kann sich auch so àußern. Overclocking und
matschige Netzteile theoretisch auch.


Marcel

Ähnliche fragen