Forums Neueste Beiträge
 

SQL-Server läuft nicht - SQLBOOT.DLL

12/09/2007 - 14:38 von Mario Kaps | Report spam
Hallo NG,

ich habe bei einem Windows 2003 SBS Premium Server folgendes Problem:

Bei dem Systemstart, noch vor der Anmeldung und dem Hinweise das einige
Dienste nicht gestartet werden konnten wird die Meldung "Your SQL Server
installation is either corrupt or has been tampered with (unable to load
SQLBOOT.DLL). Please uninstall then re-run setup to correct this problem"
Angezeigt, die man nur mit OK bestàtigen kann.

Der SQL-Server làuft nicht und wenn man versucht den SQL-Server zu starten
wird erneut die oben stehende Meldung ausgegeben. Im Eventlog wird folgendes
angezeigt:

Typ: Fehler
Quelle: Service Controll Manager
Kategorie: Keine
Ereigniskennung: 7034
Benutzer: Nicht zutreffend
Computer: SERVER01
Beschreibung: Dienst "MSSQLSERVER" wurde unerwartet beendet. Dies ist
bereits 3 mal passiert

Einige weitere Dienste laufen nicht unter anderem auch der ISA-Server ist
betroffen. Ich gehe aber mal davon aus das der ISA-Server auch den SQL-Server
benötigt, obwohl in den Diensteabhàngigkeiten nichts angegeben ist. Bei
anderen nicht laufenden Diensten (Backup-Software-Dienste) ist der SQL-Server
in den Diensteabhàngikeiten angegeben.

Meine bisherigen Recherchen haben ergeben, das das Problem mit dem entfernen
einer Instanz zusammen hàngen könne. Die vorgeschlagene Abhilfe in Form vom
aktivieren der Shared Memory-Protokolloption habe ich geprüft, doch diese ist
bereits aktiviert und das Problem besteht weiterhin...

Unter Systemsteuerung, Software sind nur zwei MSDE-Eintràge zu finden mit
dem in Klammern dahinter stehenden Angaben "(SBS Protokollierung)" und
"(Sharepoint)". Weitere Eintràge gibt es nicht.

Das gleiche gilt für die Registry unter dem Schlüssel
HKEY_CLASSES_ROOT\Installer\Products\ID_Number gibt es zwar einige Eintràge
doch auch nur die beiden oben aufgeführten Eintràge, die sich nach dem
SQL-Server anhören.

Ich hab natürlich noch nichts veràndert um die Situation nicht zu
verschlimmern...

Wie bekomme ich nun den SQL-Server wieder zum laufen? Ich bin für jeden Tip
und Hinweis dankbar!

Vorab schon einmal vielen Dank für Eure Mühe

Viele Grüße

Mario Kaps
 

Lesen sie die antworten

#1 Michael Monarch
12/09/2007 - 16:48 | Warnen spam
Servus Mario,

ausgehend davon das du aktuelle db-sicherung vorliegen hast!

1) nochmals die aktuelle Data-Files sichern
2) SQL-Server neu installieren (wie die Fehlermeldung ja vorgibt)
3) DB-Sicherung zurückspielen oder Data-Files neu aufnehmen

mfg michael

"Mario Kaps" wrote:

Hallo NG,

ich habe bei einem Windows 2003 SBS Premium Server folgendes Problem:

Bei dem Systemstart, noch vor der Anmeldung und dem Hinweise das einige
Dienste nicht gestartet werden konnten wird die Meldung "Your SQL Server
installation is either corrupt or has been tampered with (unable to load
SQLBOOT.DLL). Please uninstall then re-run setup to correct this problem"
Angezeigt, die man nur mit OK bestàtigen kann.

Der SQL-Server làuft nicht und wenn man versucht den SQL-Server zu starten
wird erneut die oben stehende Meldung ausgegeben. Im Eventlog wird folgendes
angezeigt:

Typ: Fehler
Quelle: Service Controll Manager
Kategorie: Keine
Ereigniskennung: 7034
Benutzer: Nicht zutreffend
Computer: SERVER01
Beschreibung: Dienst "MSSQLSERVER" wurde unerwartet beendet. Dies ist
bereits 3 mal passiert

Einige weitere Dienste laufen nicht unter anderem auch der ISA-Server ist
betroffen. Ich gehe aber mal davon aus das der ISA-Server auch den SQL-Server
benötigt, obwohl in den Diensteabhàngigkeiten nichts angegeben ist. Bei
anderen nicht laufenden Diensten (Backup-Software-Dienste) ist der SQL-Server
in den Diensteabhàngikeiten angegeben.

Meine bisherigen Recherchen haben ergeben, das das Problem mit dem entfernen
einer Instanz zusammen hàngen könne. Die vorgeschlagene Abhilfe in Form vom
aktivieren der Shared Memory-Protokolloption habe ich geprüft, doch diese ist
bereits aktiviert und das Problem besteht weiterhin...

Unter Systemsteuerung, Software sind nur zwei MSDE-Eintràge zu finden mit
dem in Klammern dahinter stehenden Angaben "(SBS Protokollierung)" und
"(Sharepoint)". Weitere Eintràge gibt es nicht.

Das gleiche gilt für die Registry unter dem Schlüssel
HKEY_CLASSES_ROOT\Installer\Products\ID_Number gibt es zwar einige Eintràge
doch auch nur die beiden oben aufgeführten Eintràge, die sich nach dem
SQL-Server anhören.

Ich hab natürlich noch nichts veràndert um die Situation nicht zu
verschlimmern...

Wie bekomme ich nun den SQL-Server wieder zum laufen? Ich bin für jeden Tip
und Hinweis dankbar!

Vorab schon einmal vielen Dank für Eure Mühe

Viele Grüße

Mario Kaps

Ähnliche fragen