SS2005 SP2 seltsamer Fehler bei restore der master db

30/08/2007 - 13:52 von Jochen Rieseberg | Report spam
Hallo zusammen,

ich habe folgendes Problem: die Aufgabe ist, eine Installation eines SQL
Servers auf einem Testsystem 1:1 nachzubauen; der Unterschied ist, dass der
DATA-Ordner auf dem existierenden Server auf Disk C: liegt, im Testsystem
soll er auf Disk D: liegen; damit muss auch die master db an einem anderen
Ort liegen, einfaches kopieren der Verzeichnisse, wie es manchmal gemacht
wird, geht hier also nicht. Kundenvorgabe ist aber zwingend, auch die master
über restore wiederherzustellen.
Beim Versuch, das mit dem Management Studio zu tun (Service làuft natürlich
im SingleMode!), bricht das Restore nach etwa 30 sec mit einer Fehlermeldung
"A transport-level error has occured when receiving results from the server.
(provider:Shared memory provider, error:0 - The pipe has been ended.)
(Microsoft SQL Server, Error:109)"
ab. Danach ist die master beschàdigt. Mache ich das Ganze mit sqlcmd von der
Konsole, wird Erfolg gemeldet, der Service làßt sich danach aber auch nicht
starten.
Hat irgendjemand vielleicht àhnliches schon mal erlebt??

Gruß Jochen Rieseberg
J.Rieseberg
http://www.rieseberg.de
 

Lesen sie die antworten

#1 Michael Monarch
30/08/2007 - 17:04 | Warnen spam
Hallo Jochen,

Kundenvorgaben sollte man auf den Sinn hin überprüfen!!

Wenn du den Testserver installierst kann du ja angeben wo die DB-files
liegen sollen, in deinem Fall auf D:

Beim Install wird auch eine master DB angelegt, wenn du nun die DB-Files
aufspielst (auf D) werden ja auch entsprechende Eintràge in die master DB
vorgenommen und auch die DB-Files sind nicht mehr unbedingt 1:1 die selben.

Spielst du die master DB (orginal) über die vorhandene master stimmt da
nichts mehr!

Außerdem, tut es dem Testsystem in Bezug auf "Plausiblitàt" eine Master DB
welche nicht 1:1 die Selbe ist keine Abbruch.

Ein Lösung ist vielleicht die DB's erst einzeln auf C: hochziehen und dann
auf D: zu verschieben (bedeutet Arbeit aber hauptsache der Kde ist zufrienden)

mfg michael
"Jochen Rieseberg" wrote:

Hallo zusammen,

ich habe folgendes Problem: die Aufgabe ist, eine Installation eines SQL
Servers auf einem Testsystem 1:1 nachzubauen; der Unterschied ist, dass der
DATA-Ordner auf dem existierenden Server auf Disk C: liegt, im Testsystem
soll er auf Disk D: liegen; damit muss auch die master db an einem anderen
Ort liegen, einfaches kopieren der Verzeichnisse, wie es manchmal gemacht
wird, geht hier also nicht. Kundenvorgabe ist aber zwingend, auch die master
über restore wiederherzustellen.
Beim Versuch, das mit dem Management Studio zu tun (Service làuft natürlich
im SingleMode!), bricht das Restore nach etwa 30 sec mit einer Fehlermeldung
"A transport-level error has occured when receiving results from the server.
(provider:Shared memory provider, error:0 - The pipe has been ended.)
(Microsoft SQL Server, Error:109)"
ab. Danach ist die master beschàdigt. Mache ich das Ganze mit sqlcmd von der
Konsole, wird Erfolg gemeldet, der Service làßt sich danach aber auch nicht
starten.
Hat irgendjemand vielleicht àhnliches schon mal erlebt??

Gruß Jochen Rieseberg
J.Rieseberg
http://www.rieseberg.de

Ähnliche fragen