SSTab Tabtasteproblem

02/12/2009 - 10:09 von Wilfried Dietrich | Report spam
Hallo,

ich weiß, wenn ich hier SSTab erwàhne, dann schreien viele
von Euch "dieses bugige Ding" - lass die Finger davon.
Ich habe es aber nunmal zu Hauf in meinem Projekt verbaut und
stoße immer wieder mal auf das gleiche Problem, dass beim Betàtigen
der Tab-Taste der Focus manchmal auf ein Steuerelement einer
anderen Registerkarte (Tab) springt ohne das die Registerkarte
gewechselt wird- was natürlich zu Verwirrung führt.

Kennt von Euch jemand eine einfachere Lösung als:

1.) das SSTab kompl. zu ersetzen gegen ...
2.) auf den nicht aktiven Registerkarten (Tabs) alle Controls zu
deaktivieren (.Enabled = False oder .TabStop = False)
3.) auf jedes Tab ein Frame als Container für die / mit den Controls zu
setzen und dann die Frames entsprechend enabeln. Enabled = False
auf den nicht aktiven Tabs und .Enabled = True auf dem aktiven Tab?

Schon mal Danke für einen guten Tip.
Gruß
Wilfried
 

Lesen sie die antworten

#1 Horst Heinrich Dittgens
02/12/2009 - 10:56 | Warnen spam
stoße immer wieder mal auf das gleiche Problem, dass beim Betàtigen
der Tab-Taste der Focus manchmal auf ein Steuerelement einer
anderen Registerkarte (Tab) springt ohne das die Registerkarte
gewechselt wird- was natürlich zu Verwirrung führt.



Komisch. Ist das genannte Verhalten eigentlich reproduzierbar? Ich habe das
SSTAB in diversen Fenstern und hatte von der Bedienungsseite her noch nie
irgendwelche Probleme zu verzeichnen.

Wenn ich solche wie die geschilderten hàtte, würde ich, falls das Verhalten
nicht reproduzierbar wàre,
- eine neue Form nehmen
- darauf Controls neu setzen (aber nicht kopieren)
- den gesamten Code der alten Form rüberkopieren
- alte Form entfernen
- Projekt speichern
- Projekt neu laden und neue Form umbenennen

Ähnliche fragen