Standardwebsite verwendet falsches Zertifikat

16/09/2008 - 18:42 von Markus Nett | Report spam
Hallo zusammen,
ich habe folgendes Problem:

Auf einem W2k3 x64-Server mit Exchange 2007 haben wir auf der
Standardwebsite im IIS ein Zertifikat für den internen Zugriff hinterlegt.
Dieses Zertifikat ist auf den vollen Servernamen (Bsp: server.domain.local)
ausgeschrieben. Wenn wir z.B. mit dem IE die Website aufrufen, bekommen wir
einen Zertifikatsfehler zurück. Das tatsàchlich verwendete Zertifikat lautet
nur auf den Netbios-Namen. In der IIS-Verwaltung und im Exchange-Server ist
aber nachweislich das Zertifikat mit dem internen FQDN hinterlegt.
Wenn man testweise das Zertifikat mit dem Netbios-Namen aus dem
Zertifikatsspeicher löscht, kann die Website per HTTPS nicht aufgerufen
werden. Wird es wieder importiert, funktioniert die Seite sofort wieder (ohne
IIS-Restart o.à.)

Meine Frage: Wo holt der IIS das Zertifikat mit dem Netbios-Namen her bzw.
wie kann ich es ihm ausreden?
Vielen Dank, für Eure Hilfe.

Gruß,
Markus
 

Lesen sie die antworten

#1 Bilyana Dimova
16/10/2008 - 09:12 | Warnen spam
Hallo Markus,

Kannst du bitte einige Fragen antworten:

1. Welche IIS Version hast du installiert?
2. Wo liegt die Root CA, auf diesem Server oder auf einem anderen?
3. Beim Erstellen des Zertifikat's hast du den Netbios-Namen oder den
Servername geschrieben?
4. Welchen template hast du benutzt und welche Einstellungen sind unten
"Subject Name"?

Mfg
Bilyana

"Markus Nett" wrote in message
news:
Hallo zusammen,
ich habe folgendes Problem:

Auf einem W2k3 x64-Server mit Exchange 2007 haben wir auf der
Standardwebsite im IIS ein Zertifikat für den internen Zugriff hinterlegt.
Dieses Zertifikat ist auf den vollen Servernamen (Bsp:
server.domain.local)
ausgeschrieben. Wenn wir z.B. mit dem IE die Website aufrufen, bekommen
wir
einen Zertifikatsfehler zurück. Das tatsàchlich verwendete Zertifikat
lautet
nur auf den Netbios-Namen. In der IIS-Verwaltung und im Exchange-Server
ist
aber nachweislich das Zertifikat mit dem internen FQDN hinterlegt.
Wenn man testweise das Zertifikat mit dem Netbios-Namen aus dem
Zertifikatsspeicher löscht, kann die Website per HTTPS nicht aufgerufen
werden. Wird es wieder importiert, funktioniert die Seite sofort wieder
(ohne
IIS-Restart o.à.)

Meine Frage: Wo holt der IIS das Zertifikat mit dem Netbios-Namen her bzw.
wie kann ich es ihm ausreden?
Vielen Dank, für Eure Hilfe.

Gruß,
Markus

Ähnliche fragen