Status aus zwei Zellen ermitteln

27/11/2007 - 17:11 von Besco | Report spam
Hallo miteinander

Da ich meine ersten Schritte mit Excel-Funktionen mache und nicht
weiterkomme, hoffe ich, dass mir jemand von Euch behilflich ist.

Hier mal die Aufgabenstellung:
Ich möchte Zelle A1 mit Zelle B1 vergleichen und in der Zelle C1 einen
Status ausweisen, z. B. ok oder nok.
1. Der Status der Zelle A1 hat entweder eine Formel oder als Resultat ein
Text aus der sverweis-Formel.
2. Der Status der Zelle B1 hat entweder eine Formel oder als Resultat eine
Nummer aus der sverweis-Formel.

In der Zelle C1 möchte ich folgendes Resultat ermitteln:
=Falls Zelle A1 leer (kein Resultat, jedoch Formel enthalten) ist, soll als
Resultat nichts stehen. Zelle B1 spielt zu diesem Zeitpunkt noch keine Rolle.

Falls Zelle A1 ein Text hat (Resultat aus sverweis), muss auch Zelle B1
überprüft werden. Zelle B1 könnte jetzt leer sein (nur Formel enthalten) oder
eine Zahl aus dem sverweis enthalten. Sofern keine Zahl enthalten ist, soll
als Resultat "NOK" ausgegeben werden, sofern jedoch eine Zahl enthalten ist
soll als Resultat "OK" ausgegeben werden.

Generell kann ich sagen, dass ich kein =IFTEXT oder IFBLANK usw. als check
durchführen kann, da eine Formel enthalten ist.

Ziemlich komplizierte Erklàrung. Ich hoffe, dass ich Euch nicht verwirrt
habe. Sonst kann ich immer noch ein Beispiel schicken.

Ich bedanke mich jetzt schon recht herzlich fürs durchlesen, sofern jemand
eine Lösung hat, bin ich noch "happier".

Merci und einen schönen Abend.

Gruss Besco
 

Lesen sie die antworten

#1 Alexander Wolff
27/11/2007 - 17:25 | Warnen spam
C1: =WENN(A1="";"";WENN(B1=0;"N";)&"OK") vielleicht?
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen