StepUp, ReverseRecovery, Gate-Ansteuerung

10/04/2008 - 14:51 von Michael Rübig | Report spam
Hallo Leute,
ich habe hier einen Step-Up Converter.
Uin: 70V
Uout: 150-200V
100kHz
Leistung: mehrere 100W
kontinuierlicher Betrieb.

Es ist mein erster Schaltwandler, bei dem ich eine Siliziumdiode statt
einer Schottky-Diode einsetze.
Diode: 8ETX06 von IRF/Vishay
http://www.vishay.com/docs/93030/930308et.pdf

Nach der Inbetriebnahme habe ich mir das Verhalten mal genauer
angeschaut und es passiert eigentlich auch das, was ich erwartet habe:
Der FET wird angesteuert, das Gate geht in 10-20ns von 0 auf über 10V.
Die Diode leitet deshalb rückwàrts und hört nach ca. 20Sekunden auf zu
leiten. In diesem Moment geht natürlich der Drain von 150V innerhalb von
10ns auf 0V. Durch die Miller-Kapazitàt wird das Gate wieder
aufgesteuert, der Treiber kann da nicht viel dagegen tun.
Dadurch wird das Ganze mit allen Parasiten zum Schwingen angeregt. Nach
einigen Perioden ist dann Ruhe
EMV-technisch wird das natürlich Probleme machen.

Die Fragen an die Experten in dieser Runde:

1. Was kann man dagegen tun, außer langsamer anzusteuern bzw. eine dicke
Kapazitàt (10n) zwischen Gate und Source zu packen.

2. Gibts hier eine typische Vorgehensweise?


Das Ausschalten ist ja ziemlich unkritisch, deshalb steuere ich das Gate
über 2 parallele Widerstànde (1R, 4,7R). Der 1R-Widerstand hat eine
10MQ040-Schottky in Reihe, damit man das Gate sehr schnell abschalten kann.
Geladen wird das Gate also über 4,7R, entladen über Schottky und 1R.

Ich denke mal, dass man in die Richtung langsam Einschalten <-> schnell
Anschalten optimieren muss, da man das Einschalten nicht beliebig
schnell in den Griff bekommen kann.

Eine Besonderheit ist mir noch aufgefallen, die ich mir nicht ganz
erklàren kann:
Beim Abschalten geht das Gate innerhalb von 20nsec auf fast 0V und
bleibt da auch. Die Drainspannung bewegt sich aber erst deutlich spàter
(20ns) und braucht ewig (100ns) bis sie die Ausgangsspannung erreicht
hat. Mir ist nicht klar, warum der Drain so spàt reagiert. Ein
Messfehler ist es sicherlich nicht, da die fallende Flanke am selben
Messpunkt gemessen deutlich schneller ist (und zappelt wegen Reverse
Recovery).

Michael
 

Lesen sie die antworten

#1 info2
10/04/2008 - 15:59 | Warnen spam
On 10 Apr., 14:51, Michael Rübig wrote:
Nach der Inbetriebnahme habe ich mir das Verhalten mal genauer
angeschaut und es passiert eigentlich auch das, was ich erwartet habe:
Der FET wird angesteuert, das Gate geht in 10-20ns von 0 auf über 10V.
Die Diode leitet deshalb rückwàrts und hört nach ca. 20Sekunden auf zu
leiten. In diesem Moment geht natürlich der Drain von 150V innerhalb von
10ns auf 0V. Durch die Miller-Kapazitàt wird das Gate wieder
aufgesteuert, der Treiber kann da nicht viel dagegen tun.
Dadurch wird das Ganze mit allen Parasiten zum Schwingen angeregt. Nach
einigen Perioden ist dann Ruhe
EMV-technisch wird das natürlich Probleme machen.

Die Fragen an die Experten in dieser Runde:

1. Was kann man dagegen tun, außer langsamer anzusteuern bzw. eine dicke
Kapazitàt (10n) zwischen Gate und Source zu packen.



Ferritperle(n) über die Diodenanschlüsse & FET nicht zu schnell
Einschalten.
Alles was man tut làuft auf den Kompromiss Störabstrahlung /
Effektivitàt hinaus.
Die Sperrverzögerungsladung der Diode ist meist das bestimmende.
Auch Schottky Dioden brauchen manchmal einen Ferrit.

2. Gibts hier eine typische Vorgehensweise?

Das Ausschalten ist ja ziemlich unkritisch, deshalb steuere ich das Gate
über 2 parallele Widerstànde (1R, 4,7R). Der 1R-Widerstand hat eine
10MQ040-Schottky in Reihe, damit man das Gate sehr schnell abschalten kann.
Geladen wird das Gate also über 4,7R, entladen über Schottky und 1R.

Ich denke mal, dass man in die Richtung langsam Einschalten <-> schnell
Anschalten optimieren muss, da man das Einschalten nicht beliebig
schnell in den Griff bekommen kann.

Eine Besonderheit ist mir noch aufgefallen, die ich mir nicht ganz
erklàren kann:
Beim Abschalten geht das Gate innerhalb von 20nsec auf fast 0V und
bleibt da auch. Die Drainspannung bewegt sich aber erst deutlich spàter
(20ns) und braucht ewig (100ns) bis sie die Ausgangsspannung erreicht
hat. Mir ist nicht klar, warum der Drain so spàt reagiert. Ein
Messfehler ist es sicherlich nicht, da die fallende Flanke am selben
Messpunkt gemessen deutlich schneller ist (und zappelt wegen Reverse
Recovery).



Messungenauigkeiten, und:
Misst man am Gate Anschluß, so ist noch ein parasitàrer, verteilter
Widerstand vom Anschluß zu den vielen internen Transistoren des
FET's.
Das relativiert hochstromige Gate Ansteuerung.
Manchmal auch im DS angegeben.

Raymund Hofmann

Ähnliche fragen