Suche eine Funktion (SummeWenn?)

13/01/2009 - 09:52 von Stefan Ponzelar | Report spam
Hallo,

ich habe eine Tabelle mit 2 Spalten. In der Ersten Spalte steht ein Text in
der zweiten Spalte ein Betrag.
Ich möchte nun den Betrag summieren WENN in der ersten Spalte der Text etwas
ENTHÄLT.

Kleines Beispiel: eine Einkaufliste. In der Ersten spalte gibt es immer
mehrfach folgende Werte:
Lebensmittel (Aldi)
Lebensmittel (Globus)
Lebensmittel (Lidl)
usw.
Ich möchte jetzt aus der Tabelle z.b. alles summieren was vom Aldi ist.
Versucht habe ich das mal so: =SUMMENPRODUKT((A2:A100="*Aldi*")*(B2:B100))
Das funktioniert aber leider nicht mit den Platzhaltern.

Wàre toll wenn jemand eine Lösung für dieser Problem hat.
Eine Änderung des Textes ist leider nicht möglich da die Liste noch andere
Dinge enthàlt.

gruß
Stefan
 

Lesen sie die antworten

#1 Eberhard Funke
13/01/2009 - 10:50 | Warnen spam
Am Tue, 13 Jan 2009 09:52:24 +0100 schrieb Stefan Ponzelar:


ich habe eine Tabelle mit 2 Spalten. In der Ersten Spalte steht ein Text in
der zweiten Spalte ein Betrag.
Ich möchte nun den Betrag summieren WENN in der ersten Spalte der Text etwas
ENTHÄLT.

Kleines Beispiel: eine Einkaufliste. In der Ersten spalte gibt es immer
mehrfach folgende Werte:
Lebensmittel (Aldi)
Lebensmittel (Globus)
Lebensmittel (Lidl)
usw.
Ich möchte jetzt aus der Tabelle z.b. alles summieren was vom Aldi ist.
Versucht habe ich das mal so: =SUMMENPRODUKT((A2:A100="*Aldi*")*(B2:B100))
Das funktioniert aber leider nicht mit den Platzhaltern.

Wàre toll wenn jemand eine Lösung für dieser Problem hat.



Hallo Stefan,

die Lössung hast Du selbst schon im Header gegeben:

=SUMMEWENN(A:A;"*Aldi*";B:B)

Mit freundlichen Grüssen Eberhard
XP home XL 2000
Eberhard(punkt)W(punkt)Funke(at)t-online.de

Ähnliche fragen