Suche im Tabellenblatt

18/10/2011 - 18:40 von Detlef Paschke | Report spam
Hallo,

mal wieder was für die Experten.
Ich habe ein Arbeitsblatt "Datensatz" mit vier Spalten. "BSK", "Haus",
"Ebene", "Raum und "Nummer". In einem weiteren Arbeitsblatt ist eine
Suchmaske in der in der ersten Zell die Nummer des Hauses und in die zweite
die Nummer des BSK eingetragen wird. In der nàchsten Zelle soll nun die
dazugehörige Ebene und in der nàchsten der dazugehörige Raum erscheinen.

Mit einen Datensatz habe ich diesen Ansatz für BSK:
=WENN(UND($F$7=Datensatz!$A$2)*(UND(Datensatz!$B$2=$E$7));Datensatz!$C$2;"FALSCH")

$F$7 ist in der Suchmaske die Zelle für "BSK"
Datensatz!$A$2 ist im Blatt Datensatz die erste Zelle der Spalte BSK
Datensatz!$B$2 ist im Blatt Datensatz die erste Zelle der Spalte Haus
$E$7 ist in der Suchmaske die Zelle für Haus
Datensatz!$C$2 ist im Blatt Datensatz die erste Zelle der Spalte Ebene
In der folgenden Zelle der Suchmaske ist die identische Formel mit dem
Unterschied, dass für WAHR Datensatz!$D$2 für Raum eingetragen ist.

Tja... aber das ist nur für eine Zeile in "Datensatz", wie kann ich das für
alle Daten (Zeilen) in Datensatz realisieren?
Schnödes Strg+F wird nicht gewollt ebenso wenn möglich kein VB.

Viele Grüße
Detlef Paschke
 

Lesen sie die antworten

#1 Claus Busch
18/10/2011 - 18:45 | Warnen spam
Hallo Detlef,

Am Tue, 18 Oct 2011 18:40:36 +0200 schrieb Detlef Paschke:

Ich habe ein Arbeitsblatt "Datensatz" mit vier Spalten. "BSK", "Haus",
"Ebene", "Raum und "Nummer". In einem weiteren Arbeitsblatt ist eine
Suchmaske in der in der ersten Zell die Nummer des Hauses und in die zweite
die Nummer des BSK eingetragen wird. In der nàchsten Zelle soll nun die
dazugehörige Ebene und in der nàchsten der dazugehörige Raum erscheinen.



schau dir mal die Hilfe zu Spezialfilter an.
Bei Bedarf könntest du den auch mit VBA automatisieren.


Mit freundlichen Grüßen
Claus Busch
Win XP Prof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2

Ähnliche fragen