Suche im Tabellenplatt

18/10/2011 - 18:44 von Detlef Paschke | Report spam
Hallo,

mal wieder was für die Experten.
Ich habe ein Arbeitsblatt "Datensatz" mit vier Spalten. "BSK", "Haus",
"Ebene", "Raum und "Nummer". In einem weiteren Arbeitsblatt ist eine
Suchmaske in der in der ersten Zell die Nummer des Hauses und in die zweite
die Nummer des BSK eingetragen wird. In der nàchsten Zelle soll nun die
dazugehörige Ebene und in der nàchsten der dazugehörige Raum erscheinen.

Mit einen Datensatz habe ich diesen Ansatz für BSK:
=WENN(UND($F$7=Datensatz!$A$2)*(UND(Datensatz!$B$2=$E$7));Datensatz!$C$2;"FALSCH")

$F$7 ist in der Suchmaske die Zelle für "BSK"
Datensatz!$A$2 ist im Blatt Datensatz die erste Zelle der Spalte BSK
Datensatz!$B$2 ist im Blatt Datensatz die erste Zelle der Spalte Haus
$E$7 ist in der Suchmaske die Zelle für Haus
Datensatz!$C$2 ist im Blatt Datensatz die erste Zelle der Spalte Ebene
In der folgenden Zelle der Suchmaske ist die identische Formel mit dem
Unterschied, dass für WAHR Datensatz!$D$2 für Raum eingetragen ist.

Tja... aber das ist nur für eine Zeile in "Datensatz", wie kann ich das für
alle Daten (Zeilen) in Datensatz realisieren?
Schnödes Strg+F wird nicht gewollt ebenso wenn möglich kein VB.

Viele Grüße
Detlef Paschke
 

Lesen sie die antworten

#1 Detlef Paschke
19/10/2011 - 16:49 | Warnen spam
Tja... aber das ist nur für eine Zeile in "Datensatz", wie kann ich das
für alle Daten (Zeilen) in Datensatz realisieren?
Schnödes Strg+F wird nicht gewollt ebenso wenn möglich kein VB.



Ich habe heute mit einem neuen Ansatz Experimentiert

für die Ebenen:
=INDEX(Datensatz!$C:$C;VERGLEICH($F$18;Datensatz!$A:$A;0))

Datensatz!$C:$C ist die Spalte der Ebenen
$F$18 ist in der Suchmaske die Eingabe der BSK
Datensatz!$A:$A ist die Spalte der BSK

und für den Raum:
=INDEX(Datensatz!$D:$D;VERGLEICH($E$18;Datensatz!$B:$B;0))

Datensatz!$C:$C ist die Spalte der Raumnummern
$F$18 ist in der Suchmaske die Eingabe des Hauses
Datensatz!$B:$B ist die Spalte der Hàuser

jetzt fehlt mir aber eine sinnvolle Verknüpfung der beiden den: Tippe ich in
der Suchmaske bei Haus z.B. 60 und bei BSK A088 ein erscheint bei Raum eine
05 da 05 der erste eingetragene Raum im Haus 60 ist und bei Ebene angenommen
1 da Ebene 1 die erste Eingetragene Ebene mit BSK A088 ist.
Es sollen aber immer beide Suchkriterien übereinstimmen, in diesem Fall BSK
A1 in Haus 49.

Ich habe meine Tabelle mal unter http://schabau.dyndns.org/home/BSK.xls
freigegeben.

Viele Grüße
Detlef Paschke

Ähnliche fragen