SUCHEN, FINDEN, VERGLEICH, SVERWEIS oder doch ganz anders?

22/05/2009 - 13:57 von MaKrue | Report spam
Hallo Forum,

ich komme leider nicht weiter mit meinem kryptischen Excel-
Kenntnissen. Ich hoffe, dass mir hier jemand einen entscheidenden
Hinweis geben kann ...

Ich habe also zwei Tabellen
In Tabelle1 stehen in nur einer Spalte kurze Texte (Abkürzungen)
In etwas so:

A1
-
abc wer
me haus
zum Bei
ber wo




In Tabelle 2 stehen ebenfalls Abkürzungen mit den dazugehörigen
Ausschreibungen. In etwa so:

A1 | B1
-
abc wer | abcdef wert
po dah | post dahin
ber wo | berricht wohin
me haus | mein Haustelefon
ei Anr | ein Anruf


Ich möchte nun gerne die Texte aus Tabelle1 mit den Texten aus Tabelle
2 (jeweils Spalte A) vergleichen. Wenn der Wert zb. aus Tabelle1/A1 in
Tabelle 2, Spalte A vorkommt, möchte ich in Tabelle zwei die
dazugehörige Ausschreibung in Tablle1, Spalte B haben.

Wie kann ich das hinbekommen? Kann ich das mittels Funktionen und wenn
ja, welche?

Für eine Antwort wàre ich sehr dankbar.

Marleene
 

Lesen sie die antworten

#1 Dietmar Vollmeier
22/05/2009 - 14:52 | Warnen spam
Servus Marleene!

*MaKrue* schrieb am 22.05.2009 um 13:57 Uhr...
Hallo Forum,



Newsgroup, kein Forum ;-)

Ich habe also zwei Tabellen
In Tabelle1 stehen in nur einer Spalte kurze Texte (Abkürzungen)
In etwas so:

A1
-
[...]

In Tabelle 2 stehen ebenfalls Abkürzungen mit den dazugehörigen
Ausschreibungen. In etwa so:

A1 | B1
-
[...]

Ich möchte nun gerne die Texte aus Tabelle1 mit den Texten aus Tabelle
2 (jeweils Spalte A) vergleichen. Wenn der Wert zb. aus Tabelle1/A1 in
Tabelle 2, Spalte A vorkommt, möchte ich in Tabelle zwei die
dazugehörige Ausschreibung in Tablle1, Spalte B haben.

Wie kann ich das hinbekommen? Kann ich das mittels Funktionen und wenn
ja, welche?



Da gibt es, wie du in deinem Betreff schon geschrieben hast, mehrere
Möglichkeiten. Hier mal zwei davon, such dir eine aus:

=WENN(ISTNV(SVERWEIS(A1;Tabelle2!A$1:B$10;2;FALSCH));"";SVERWEIS(A1;Tabelle2!A$1:B$10;2;FALSCH))
=WENN(ISTNV(INDEX(Tabelle2!B$1:B$10;VERGLEICH(A1;Tabelle2!A$1:A$10;0)));"";INDEX(Tabelle2!B$1:B$10;VERGLEICH(A1;Tabelle2!A$1:A$10;0)))

Für eine Antwort wàre ich sehr dankbar.



HTH
und tschüss | Jedem das Seine, mir das meiste!
Didi |

Ähnliche fragen