Summeformel Wochentage liefert falsche Ergebnisse

09/11/2013 - 16:25 von Ahmed Martens | Report spam
Hallo Leute,

ich möchte mittels Formeln alle Werktage in einem Zeitraum abzüglich der
Feiertage als Wochtag ermitteln.

Beispiel:

Arbeitstage im Jahr: 2013

Anzahl Werktage
A B C D
von bis Tage
01.01.2013 31.12.2013 50* Anzahl Mo.
01.01.2013 31.12.2013 52 Anzahl Di.
01.01.2013 31.12.2013 50 Anzahl Mi,
01.01.2013 31.12.2013 49 Anzahl Do.
01.01.2013 31.12.2013 51 Anzahl Fr.
01.01.2013 31.12.2013 42 Anzahl Sa.
01.01.2013 31.12.2013 51 Anzahl So.
Wochentage o. Feiertage: 345

Summe AT o. Feiertage: 252



Bundesland: Schleswig-Holstein
Feiertage für: 2013
A B C D
01.01.2013 09.05.2013 <¢1:B25
29.03.2013 20.05.2013
31.03.2013 03.10.2013
01.04.2013 25.12.2013
01.05.2013 26.12.2013


Die Formel lautet:
*
{=SUMME((WOCHENTAG(ZEILE(INDIREKT(A5&":"&B5));2)=1)*1)-SUMME((WOCHENTAG(A21:D25;2)=1)*1)}

Leider liefert die Formel falsche Ergebnisse, wenn die Zellen in den
Feiertagsbereichen leer sind.

Wie kann die die Formel anpassen, dass ich auch leere Bereiche einfach
mit berücksichtigen kann?

Vielen Dank im voraus.

Gruß Ahmed

Antworten bitte nur in der Newsgroup
Windows 7 64bit Home Premium
Office Prof. 2010
 

Lesen sie die antworten

#1 Claus Busch
09/11/2013 - 16:37 | Warnen spam
Hallo Ahmed,

Am Sat, 9 Nov 2013 16:25:27 +0100 schrieb Ahmed Martens:

Arbeitstage im Jahr: 2013

Anzahl Werktage
A B C D
von bis Tage
01.01.2013 31.12.2013 50* Anzahl Mo.
01.01.2013 31.12.2013 52 Anzahl Di.
01.01.2013 31.12.2013 50 Anzahl Mi,
01.01.2013 31.12.2013 49 Anzahl Do.
01.01.2013 31.12.2013 51 Anzahl Fr.
01.01.2013 31.12.2013 42 Anzahl Sa.
01.01.2013 31.12.2013 51 Anzahl So.
Wochentage o. Feiertage: 345

Summe AT o. Feiertage: 252



Bundesland: Schleswig-Holstein
Feiertage für: 2013
A B C D
01.01.2013 09.05.2013 <¢1:B25
29.03.2013 20.05.2013
31.03.2013 03.10.2013
01.04.2013 25.12.2013
01.05.2013 26.12.2013

Die Formel lautet:
*
{=SUMME((WOCHENTAG(ZEILE(INDIREKT(A5&":"&B5));2)=1)*1)-SUMME((WOCHENTAG(A21:D25;2)=1)*1)}



warum nimmst du nicht einfach NETTOARBEITSTAGE?
Sind darin die Zellen A21:B25 leer, bekommst du die Wochentage ohne die
Feiertage:
=NETTOARBEITSTAGE(A2;B2;A21:B25)


Mit freundlichen Grüßen
Claus
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen